summaryrefslogtreecommitdiffstats
path: root/reco/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'reco/PKGBUILD')
-rw-r--r--reco/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/reco/PKGBUILD b/reco/PKGBUILD
new file mode 100644
index 0000000..b798f19
--- /dev/null
+++ b/reco/PKGBUILD
@@ -0,0 +1,24 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3
4pkgname='reco'
5pkgver=3.0.1
6pkgrel=1
7pkgdesc='An audio recording app designed for elementary OS'
8arch=('x86_64')
9url='https://github.com/ryonakano/reco'
10license=('GPL3')
11depends=('granite' 'gstreamer')
12makedepends=('meson' 'vala' 'libhandy')
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
14sha256sums=('aada1ba503514ce842d84f0f460b5a2af6942c93b82d7bb4c1b8972cec421738')
15
16build() {
17 arch-meson "${pkgname}-${pkgver}" build
18 meson compile -C build
19}
20
21package() {
22 DESTDIR="${pkgdir}" meson install -C build
23 install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}-${pkgver}/README.md"
24}