summaryrefslogtreecommitdiffstats
path: root/python-types-requests/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'python-types-requests/PKGBUILD')
-rw-r--r--python-types-requests/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/python-types-requests/PKGBUILD b/python-types-requests/PKGBUILD
new file mode 100644
index 0000000..8ebc9ee
--- /dev/null
+++ b/python-types-requests/PKGBUILD
@@ -0,0 +1,24 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=python-types-requests
4_name=${pkgname#python-}
5pkgver=2.27.3
6pkgrel=1
7pkgdesc="Typing stubs for requests"
8arch=('any')
9url="https://pypi.org/project/types-requests/"
10license=('Apache')
11depends=('python')
12makedepends=('python-setuptools')
13source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
14sha256sums=('9fe61821910eb5b33bc774165d0c8fbdf933902ef57b0d5040f96b59bc428efa')
15
16build() {
17 cd "$_name-$pkgver"
18 python setup.py build
19}
20
21package() {
22 cd "$_name-$pkgver"
23 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
24}