summaryrefslogtreecommitdiffstats
path: root/python-scrape-schema-recipe
diff options
context:
space:
mode:
Diffstat (limited to 'python-scrape-schema-recipe')
m---------python-scrape-schema-recipe21
-rw-r--r--python-scrape-schema-recipe/.SRCINFO18
-rw-r--r--python-scrape-schema-recipe/PKGBUILD23
3 files changed, 41 insertions, 21 deletions
diff --git a/python-scrape-schema-recipe b/python-scrape-schema-recipe
deleted file mode 160000
Subproject a25f40767d4589f4ea0c17c8841fde4d38619b8
diff --git a/python-scrape-schema-recipe/.SRCINFO b/python-scrape-schema-recipe/.SRCINFO
new file mode 100644
index 0000000..c05e8eb
--- /dev/null
+++ b/python-scrape-schema-recipe/.SRCINFO
@@ -0,0 +1,18 @@
1pkgbase = python-scrape-schema-recipe
2 pkgdesc = Scrapes food recipes from HTML into Python dictionaries
3 pkgver = 0.2.0
4 pkgrel = 1
5 url = https://github.com/micahcochran/scrape-schema-recipe
6 arch = any
7 license = Apache
8 makedepends = python-setuptools
9 depends = python-dataclasses
10 depends = python-extruct
11 depends = python-importlib_resources
12 depends = python-isodate
13 depends = python-requests
14 depends = python-typeshed-git
15 source = python-scrape-schema-recipe-0.2.0.tar.gz::https://github.com/micahcochran/scrape-schema-recipe/archive/v0.2.0.tar.gz
16 sha256sums = ecc253c82a9346c66e77005680a3f746a2feca7292bbcab0c4357b2757a0d1bf
17
18pkgname = python-scrape-schema-recipe
diff --git a/python-scrape-schema-recipe/PKGBUILD b/python-scrape-schema-recipe/PKGBUILD
new file mode 100644
index 0000000..c1e894a
--- /dev/null
+++ b/python-scrape-schema-recipe/PKGBUILD
@@ -0,0 +1,23 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2pkgname=python-scrape-schema-recipe
3_pkgname=scrape-schema-recipe
4pkgver=0.2.0
5pkgrel=1
6pkgdesc="Scrapes food recipes from HTML into Python dictionaries"
7arch=('any')
8url="https://github.com/micahcochran/scrape-schema-recipe"
9license=('Apache')
10depends=('python-dataclasses' 'python-extruct' 'python-importlib_resources' 'python-isodate' 'python-requests' 'python-typeshed-git')
11makedepends=('python-setuptools')
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
13sha256sums=('ecc253c82a9346c66e77005680a3f746a2feca7292bbcab0c4357b2757a0d1bf')
14
15build() {
16 cd "${_pkgname}-${pkgver}"
17 python setup.py build
18}
19
20package() {
21 cd "${_pkgname}-${pkgver}"
22 python setup.py install --root="$pkgdir" --optimize=1
23}