diff options
Diffstat (limited to 'python-scrape-schema-recipe/PKGBUILD')
-rw-r--r-- | python-scrape-schema-recipe/PKGBUILD | 23 |
1 files changed, 23 insertions, 0 deletions
diff --git a/python-scrape-schema-recipe/PKGBUILD b/python-scrape-schema-recipe/PKGBUILD new file mode 100644 index 0000000..c1e894a --- /dev/null +++ b/python-scrape-schema-recipe/PKGBUILD | |||
@@ -0,0 +1,23 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | pkgname=python-scrape-schema-recipe | ||
3 | _pkgname=scrape-schema-recipe | ||
4 | pkgver=0.2.0 | ||
5 | pkgrel=1 | ||
6 | pkgdesc="Scrapes food recipes from HTML into Python dictionaries" | ||
7 | arch=('any') | ||
8 | url="https://github.com/micahcochran/scrape-schema-recipe" | ||
9 | license=('Apache') | ||
10 | depends=('python-dataclasses' 'python-extruct' 'python-importlib_resources' 'python-isodate' 'python-requests' 'python-typeshed-git') | ||
11 | makedepends=('python-setuptools') | ||
12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz") | ||
13 | sha256sums=('ecc253c82a9346c66e77005680a3f746a2feca7292bbcab0c4357b2757a0d1bf') | ||
14 | |||
15 | build() { | ||
16 | cd "${_pkgname}-${pkgver}" | ||
17 | python setup.py build | ||
18 | } | ||
19 | |||
20 | package() { | ||
21 | cd "${_pkgname}-${pkgver}" | ||
22 | python setup.py install --root="$pkgdir" --optimize=1 | ||
23 | } | ||