summaryrefslogtreecommitdiffstats
path: root/python-scrape-schema-recipe/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2021-10-29 01:30:24 +0300
committerYigit Sever2021-10-29 01:30:24 +0300
commit31d147b20c67d95a9e306d0749200bf964ac42af (patch)
treeb0fbe2bb5aa0fec9983746a91d188643ca93466d /python-scrape-schema-recipe/PKGBUILD
parent4a31e5e0f3442a4a5ec9fba94f7bbc2c88312c69 (diff)
downloadpackages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.gz
packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.bz2
packages-31d147b20c67d95a9e306d0749200bf964ac42af.zip
Use actual files instead of submodules
Diffstat (limited to 'python-scrape-schema-recipe/PKGBUILD')
-rw-r--r--python-scrape-schema-recipe/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/python-scrape-schema-recipe/PKGBUILD b/python-scrape-schema-recipe/PKGBUILD
new file mode 100644
index 0000000..c1e894a
--- /dev/null
+++ b/python-scrape-schema-recipe/PKGBUILD
@@ -0,0 +1,23 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2pkgname=python-scrape-schema-recipe
3_pkgname=scrape-schema-recipe
4pkgver=0.2.0
5pkgrel=1
6pkgdesc="Scrapes food recipes from HTML into Python dictionaries"
7arch=('any')
8url="https://github.com/micahcochran/scrape-schema-recipe"
9license=('Apache')
10depends=('python-dataclasses' 'python-extruct' 'python-importlib_resources' 'python-isodate' 'python-requests' 'python-typeshed-git')
11makedepends=('python-setuptools')
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
13sha256sums=('ecc253c82a9346c66e77005680a3f746a2feca7292bbcab0c4357b2757a0d1bf')
14
15build() {
16 cd "${_pkgname}-${pkgver}"
17 python setup.py build
18}
19
20package() {
21 cd "${_pkgname}-${pkgver}"
22 python setup.py install --root="$pkgdir" --optimize=1
23}