summaryrefslogtreecommitdiffstats
path: root/python-pymc
diff options
context:
space:
mode:
Diffstat (limited to 'python-pymc')
-rw-r--r--python-pymc/.AURINFO21
-rw-r--r--python-pymc/.SRCINFO21
-rw-r--r--python-pymc/PKGBUILD33
3 files changed, 75 insertions, 0 deletions
diff --git a/python-pymc/.AURINFO b/python-pymc/.AURINFO
new file mode 100644
index 0000000..2b6b262
--- /dev/null
+++ b/python-pymc/.AURINFO
@@ -0,0 +1,21 @@
1pkgbase = python-pymc
2 pkgdesc = Markov chain Monte Carlo for Python
3 pkgver = 2.3.3
4 pkgrel = 1
5 url = https://github.com/pymc-devs/pymc
6 arch = i686
7 arch = x86_64
8 license = MIT
9 makedepends = gcc-fortran
10 source = https://pypi.python.org/packages/source/p/pymc/pymc-2.3.3.tar.gz
11 md5sums = 99645bf558a41376be0e687ccf90a39f
12
13pkgname = python-pymc
14 depends = python-numpy
15 optdepends = python-scipy
16 optdepends = python-matplotlib
17 optdepends = python-pytables
18 optdepends = ipython
19 optdepends = pydot
20 optdepends = python-nose
21
diff --git a/python-pymc/.SRCINFO b/python-pymc/.SRCINFO
new file mode 100644
index 0000000..44eac1d
--- /dev/null
+++ b/python-pymc/.SRCINFO
@@ -0,0 +1,21 @@
1pkgbase = python-pymc
2 pkgdesc = Markov chain Monte Carlo for Python
3 pkgver = 2.3.8
4 pkgrel = 1
5 url = https://github.com/pymc-devs/pymc
6 arch = i686
7 arch = x86_64
8 license = MIT
9 makedepends = gcc-fortran
10 source = https://github.com/pymc-devs/pymc/archive/v2.3.8.tar.gz
11 sha256sums = 200a28469d574a370fa9b55cd92f112f8ad09f71674bdae514437039e953689b
12
13pkgname = python-pymc
14 depends = python-numpy
15 optdepends = python-scipy
16 optdepends = python-matplotlib
17 optdepends = python-pytables
18 optdepends = ipython
19 optdepends = pydot
20 optdepends = python-nose
21
diff --git a/python-pymc/PKGBUILD b/python-pymc/PKGBUILD
new file mode 100644
index 0000000..23dfb80
--- /dev/null
+++ b/python-pymc/PKGBUILD
@@ -0,0 +1,33 @@
1# Contributor: xia0er <xia0er@gmail.com>
2pkgname=python-pymc
3pkgver=2.3.8
4pkgrel=1
5pkgdesc="Markov chain Monte Carlo for Python"
6arch=('i686' 'x86_64')
7url="https://github.com/pymc-devs/pymc"
8license=('MIT')
9source=("https://github.com/pymc-devs/pymc/archive/v${pkgver}.tar.gz")
10makedepends=("gcc-fortran")
11sha256sums=('200a28469d574a370fa9b55cd92f112f8ad09f71674bdae514437039e953689b')
12
13package_python2_pymc() {
14 depends=('python2-numpy')
15 optdepends=('python2-scipy' 'python2-matplotlib' 'python2-pytables' 'ipython2' 'pydot' 'python2-nose')
16
17 cd $srcdir/pymc-$pkgver
18 export LDFLAGS="$LDFLAGS -shared"
19 python2 setup.py config_fc --fcompiler=gnu95 build
20 python2 setup.py install --prefix=/usr --root=$pkgdir || return 1
21}
22
23package() {
24 depends=('python-numpy')
25 optdepends=('python-scipy' 'python-matplotlib' 'python-pytables' 'ipython' 'pydot' 'python-nose')
26
27 cd $srcdir/pymc-$pkgver
28 export LDFLAGS="$LDFLAGS -shared"
29 python setup.py config_fc --fcompiler=gnu95 build
30 python setup.py install --prefix=/usr --root=$pkgdir || return 1
31}
32
33