diff options
Diffstat (limited to 'python-html-text')
-rw-r--r-- | python-html-text/.SRCINFO | 15 | ||||
-rw-r--r-- | python-html-text/PKGBUILD | 23 |
2 files changed, 38 insertions, 0 deletions
diff --git a/python-html-text/.SRCINFO b/python-html-text/.SRCINFO new file mode 100644 index 0000000..f2ecb42 --- /dev/null +++ b/python-html-text/.SRCINFO | |||
@@ -0,0 +1,15 @@ | |||
1 | pkgbase = python-html-text | ||
2 | pkgdesc = Python library to extract text from HTML | ||
3 | pkgver = 0.6.2 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/zytedata/html-text | ||
6 | arch = any | ||
7 | license = MIT | ||
8 | makedepends = python-build | ||
9 | makedepends = python-installer | ||
10 | makedepends = python-wheel | ||
11 | depends = python-lxml | ||
12 | source = python-html-text-0.6.2.tar.gz::https://github.com/zytedata/html-text/archive/0.6.2.tar.gz | ||
13 | sha256sums = 2bda73192e3009bacb626c8feacc9ab5f0685947eb5847e181fb1d330410bcc3 | ||
14 | |||
15 | pkgname = python-html-text | ||
diff --git a/python-html-text/PKGBUILD b/python-html-text/PKGBUILD new file mode 100644 index 0000000..1cb0452 --- /dev/null +++ b/python-html-text/PKGBUILD | |||
@@ -0,0 +1,23 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | pkgname=python-html-text | ||
3 | _pkgname=html-text | ||
4 | pkgver=0.6.2 | ||
5 | pkgrel=1 | ||
6 | pkgdesc="Python library to extract text from HTML" | ||
7 | arch=('any') | ||
8 | url="https://github.com/zytedata/html-text" | ||
9 | license=('MIT') | ||
10 | depends=(python-lxml) | ||
11 | makedepends=(python-build python-installer python-wheel) | ||
12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") | ||
13 | sha256sums=('2bda73192e3009bacb626c8feacc9ab5f0685947eb5847e181fb1d330410bcc3') | ||
14 | |||
15 | build() { | ||
16 | cd "${_pkgname}-${pkgver}" | ||
17 | python -m build --wheel --no-isolation | ||
18 | } | ||
19 | |||
20 | package() { | ||
21 | cd "${_pkgname}-${pkgver}" | ||
22 | python -m installer --destdir="$pkgdir" dist/*.whl | ||
23 | } | ||