diff options
Diffstat (limited to 'python-extruct/PKGBUILD')
-rw-r--r-- | python-extruct/PKGBUILD | 24 |
1 files changed, 0 insertions, 24 deletions
diff --git a/python-extruct/PKGBUILD b/python-extruct/PKGBUILD deleted file mode 100644 index 3aaf859..0000000 --- a/python-extruct/PKGBUILD +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | pkgname=python-extruct | ||
3 | _pkgname=extruct | ||
4 | pkgver=0.13.0 | ||
5 | pkgrel=1 | ||
6 | pkgdesc="Extract embedded metadata from HTML markup" | ||
7 | arch=('any') | ||
8 | url="https://github.com/scrapinghub/extruct" | ||
9 | license=('custom') | ||
10 | depends=('python-lxml' 'python-requests' 'python-rdflib' 'python-rdflib-jsonld' 'python-pyrdfa3' 'python-mf2py' 'python-six' 'python-w3lib' 'python-html-text' 'python-jstyleson') | ||
11 | makedepends=('python-setuptools') | ||
12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz") | ||
13 | sha256sums=('2bf4d8aaf9cfd2ea27bac256e5cabd601a480a47f49b9531ac8bfe3b42a9c74f') | ||
14 | |||
15 | build() { | ||
16 | cd "${_pkgname}-${pkgver}" | ||
17 | python setup.py build | ||
18 | } | ||
19 | |||
20 | package() { | ||
21 | cd "${_pkgname}-${pkgver}" | ||
22 | python setup.py install --root="$pkgdir" --optimize=1 | ||
23 | install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/" | ||
24 | } | ||