summaryrefslogtreecommitdiffstats
path: root/ouch
diff options
context:
space:
mode:
Diffstat (limited to 'ouch')
-rw-r--r--ouch/.SRCINFO8
-rw-r--r--ouch/PKGBUILD8
2 files changed, 7 insertions, 9 deletions
diff --git a/ouch/.SRCINFO b/ouch/.SRCINFO
index 27bd7fc..7f28a17 100644
--- a/ouch/.SRCINFO
+++ b/ouch/.SRCINFO
@@ -1,14 +1,14 @@
1pkgbase = ouch 1pkgbase = ouch
2 pkgdesc = Painless compression and decompression in the terminal 2 pkgdesc = Painless compression and decompression in the terminal
3 pkgver = 0.4.0 3 pkgver = 0.4.1
4 pkgrel = 2 4 pkgrel = 1
5 url = https://github.com/ouch-org/ouch 5 url = https://github.com/ouch-org/ouch
6 arch = x86_64 6 arch = x86_64
7 license = MIT 7 license = MIT
8 makedepends = cargo 8 makedepends = cargo
9 conflicts = ouch-git 9 conflicts = ouch-git
10 conflicts = ouch-bin 10 conflicts = ouch-bin
11 source = ouch-0.4.0.tar.gz::https://github.com/ouch-org/ouch/archive/refs/tags/0.4.0.tar.gz 11 source = ouch-0.4.1.tar.gz::https://github.com/ouch-org/ouch/archive/refs/tags/0.4.1.tar.gz
12 sha256sums = 3e126f00e1ad82ef4abfd28f86dac53b366a29de6a70359e734ecc8748f580fc 12 sha256sums = b0fcd6bbe6c66544b5bf1167d72605427c5cc6afae564f23f3eff5ea22b01b79
13 13
14pkgname = ouch 14pkgname = ouch
diff --git a/ouch/PKGBUILD b/ouch/PKGBUILD
index 0d3cfee..c85e3e9 100644
--- a/ouch/PKGBUILD
+++ b/ouch/PKGBUILD
@@ -1,8 +1,8 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com> 1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2 2
3pkgname=ouch 3pkgname=ouch
4pkgver=0.4.0 4pkgver=0.4.1
5pkgrel=2 5pkgrel=1
6pkgdesc="Painless compression and decompression in the terminal" 6pkgdesc="Painless compression and decompression in the terminal"
7arch=('x86_64') 7arch=('x86_64')
8url="https://github.com/ouch-org/ouch" 8url="https://github.com/ouch-org/ouch"
@@ -10,12 +10,10 @@ license=('MIT')
10makedepends=('cargo') 10makedepends=('cargo')
11conflicts=(${pkgname}-git ${pkgname}-bin) 11conflicts=(${pkgname}-git ${pkgname}-bin)
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz") 12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
13sha256sums=('3e126f00e1ad82ef4abfd28f86dac53b366a29de6a70359e734ecc8748f580fc') 13sha256sums=('b0fcd6bbe6c66544b5bf1167d72605427c5cc6afae564f23f3eff5ea22b01b79')
14 14
15prepare() { 15prepare() {
16 cd "$srcdir/$pkgname-$pkgver" 16 cd "$srcdir/$pkgname-$pkgver"
17 # TODO: Remove on next release <27-11-22, yigit> #
18 rm -f rust-toolchain
19 cargo fetch --locked --target "$CARCH-unknown-linux-gnu" 17 cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
20} 18}
21 19