diff options
Diffstat (limited to 'ldm')
-rw-r--r-- | ldm/.SRCINFO | 19 | ||||
-rw-r--r-- | ldm/.gitignore | 4 | ||||
-rw-r--r-- | ldm/PKGBUILD | 31 | ||||
-rw-r--r-- | ldm/ldm.install | 11 |
4 files changed, 65 insertions, 0 deletions
diff --git a/ldm/.SRCINFO b/ldm/.SRCINFO new file mode 100644 index 0000000..3a6dbee --- /dev/null +++ b/ldm/.SRCINFO | |||
@@ -0,0 +1,19 @@ | |||
1 | pkgbase = ldm | ||
2 | pkgdesc = A lightweight device mounter | ||
3 | pkgver = 0.8 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/LemonBoy/ldm | ||
6 | install = ldm.install | ||
7 | arch = i686 | ||
8 | arch = x86_64 | ||
9 | arch = armv7h | ||
10 | license = MIT | ||
11 | depends = udev | ||
12 | depends = util-linux | ||
13 | depends = glib2 | ||
14 | provides = ldm | ||
15 | conflicts = ldm-git | ||
16 | source = ldm-0.8.tar.gz::http://github.com/lemonboy/ldm/archive/v0.8.tar.gz | ||
17 | sha256sums = e471453e6ae9fa91d6150fe13c01587dd8e15a3f64665d0556ad7e8398dc46ef | ||
18 | |||
19 | pkgname = ldm | ||
diff --git a/ldm/.gitignore b/ldm/.gitignore new file mode 100644 index 0000000..05c6d4d --- /dev/null +++ b/ldm/.gitignore | |||
@@ -0,0 +1,4 @@ | |||
1 | * | ||
2 | !.gitignore | ||
3 | !.SRCINFO | ||
4 | !PKGBUILD | ||
diff --git a/ldm/PKGBUILD b/ldm/PKGBUILD new file mode 100644 index 0000000..57f7228 --- /dev/null +++ b/ldm/PKGBUILD | |||
@@ -0,0 +1,31 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: The Lemon Man | ||
3 | |||
4 | pkgname=ldm | ||
5 | pkgver=0.8 | ||
6 | pkgrel=1 | ||
7 | pkgdesc="A lightweight device mounter" | ||
8 | arch=('i686' 'x86_64' 'armv7h') | ||
9 | url="https://github.com/LemonBoy/ldm" | ||
10 | license=('MIT') | ||
11 | depends=('udev' 'util-linux' 'glib2') | ||
12 | provides=('ldm') | ||
13 | conflicts=('ldm-git') | ||
14 | install=$pkgname.install | ||
15 | source=("$pkgname-$pkgver.tar.gz"::"http://github.com/lemonboy/$pkgname/archive/v$pkgver.tar.gz") | ||
16 | sha256sums=('e471453e6ae9fa91d6150fe13c01587dd8e15a3f64665d0556ad7e8398dc46ef') | ||
17 | |||
18 | build() { | ||
19 | export PATH=$PATH:/usr/bin/core_perl | ||
20 | cd "$srcdir/$pkgname-$pkgver" | ||
21 | make | ||
22 | } | ||
23 | |||
24 | package() { | ||
25 | export PATH=$PATH:/usr/bin/core_perl | ||
26 | cd "$srcdir/$pkgname-$pkgver" | ||
27 | make PREFIX=/usr SBINDIR=/usr/bin DESTDIR="$pkgdir" install | ||
28 | |||
29 | install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" | ||
30 | } | ||
31 | |||
diff --git a/ldm/ldm.install b/ldm/ldm.install new file mode 100644 index 0000000..d59f404 --- /dev/null +++ b/ldm/ldm.install | |||
@@ -0,0 +1,11 @@ | |||
1 | post_install() { | ||
2 | echo 'ldm expects a config file at /etc/ldm.conf containing your user name.' | ||
3 | echo 'Just add this line into it:' | ||
4 | echo 'MOUNT_OWNER=<your user name>' | ||
5 | echo 'BASE_MOUNTPOINT=/mnt/' | ||
6 | } | ||
7 | post_upgrade() { | ||
8 | if [ ! -f /etc/ldm.conf ]; then | ||
9 | echo 'NOTE: The configuration file has been moved to /etc/ldm.conf' | ||
10 | fi | ||
11 | } | ||