summaryrefslogtreecommitdiffstats
path: root/ldm/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'ldm/PKGBUILD')
-rw-r--r--ldm/PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/ldm/PKGBUILD b/ldm/PKGBUILD
index c493f01..57f7228 100644
--- a/ldm/PKGBUILD
+++ b/ldm/PKGBUILD
@@ -1,9 +1,9 @@
1## ldm PKGBUILD 1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Maintainer: The Lemon Man 2# Contributor: The Lemon Man
3 3
4pkgname=ldm 4pkgname=ldm
5pkgver=0.7 5pkgver=0.8
6pkgrel=2 6pkgrel=1
7pkgdesc="A lightweight device mounter" 7pkgdesc="A lightweight device mounter"
8arch=('i686' 'x86_64' 'armv7h') 8arch=('i686' 'x86_64' 'armv7h')
9url="https://github.com/LemonBoy/ldm" 9url="https://github.com/LemonBoy/ldm"
@@ -13,11 +13,7 @@ provides=('ldm')
13conflicts=('ldm-git') 13conflicts=('ldm-git')
14install=$pkgname.install 14install=$pkgname.install
15source=("$pkgname-$pkgver.tar.gz"::"http://github.com/lemonboy/$pkgname/archive/v$pkgver.tar.gz") 15source=("$pkgname-$pkgver.tar.gz"::"http://github.com/lemonboy/$pkgname/archive/v$pkgver.tar.gz")
16sha256sums=('fb464bffec5b7d0680009b43a95881e8c02ec07e84d6f7fb05206d666dc44bdb') 16sha256sums=('e471453e6ae9fa91d6150fe13c01587dd8e15a3f64665d0556ad7e8398dc46ef')
17
18prepare() {
19 cd "$srcdir/$pkgname-$pkgver"
20}
21 17
22build() { 18build() {
23 export PATH=$PATH:/usr/bin/core_perl 19 export PATH=$PATH:/usr/bin/core_perl
@@ -28,7 +24,7 @@ build() {
28package() { 24package() {
29 export PATH=$PATH:/usr/bin/core_perl 25 export PATH=$PATH:/usr/bin/core_perl
30 cd "$srcdir/$pkgname-$pkgver" 26 cd "$srcdir/$pkgname-$pkgver"
31 make PREFIX=/usr DESTDIR="$pkgdir" install 27 make PREFIX=/usr SBINDIR=/usr/bin DESTDIR="$pkgdir" install
32 28
33 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" 29 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
34} 30}