summaryrefslogtreecommitdiffstats
path: root/helmsman
diff options
context:
space:
mode:
Diffstat (limited to 'helmsman')
-rw-r--r--helmsman/.SRCINFO8
-rw-r--r--helmsman/PKGBUILD24
2 files changed, 17 insertions, 15 deletions
diff --git a/helmsman/.SRCINFO b/helmsman/.SRCINFO
index afe4a0d..a8ab0dd 100644
--- a/helmsman/.SRCINFO
+++ b/helmsman/.SRCINFO
@@ -1,18 +1,18 @@
1pkgbase = helmsman 1pkgbase = helmsman
2 pkgdesc = Helm Charts as Code 2 pkgdesc = Helm Charts as Code
3 pkgver = 3.6.3 3 pkgver = 3.15.1
4 pkgrel = 1 4 pkgrel = 1
5 url = https://github.com/Praqma/helmsman 5 url = https://github.com/Praqma/helmsman
6 arch = x86_64 6 arch = x86_64
7 arch = i686 7 arch = i686
8 license = MIT 8 license = MIT
9 makedepends = go 9 makedepends = go
10 depends = helm
10 depends = helm-diff 11 depends = helm-diff
11 depends = kubectl 12 depends = kubectl
12 optdepends = ruby-hiera-eyaml: backend for secret encryption 13 optdepends = ruby-hiera-eyaml: backend for secret encryption
13 optdepends = helm-secrets: backend for secret encryption 14 optdepends = helm-secrets: backend for secret encryption
14 source = https://github.com/Praqma/helmsman/archive/v3.6.3/helmsman-3.6.3.tar.gz 15 source = helmsman-3.15.1.tar.gz::https://github.com/Praqma/helmsman/archive/v3.15.1/helmsman-3.15.1.tar.gz
15 sha256sums = 05ce86066028ed0fbb99902018953107432727abe297745de4013815b5bf6781 16 sha256sums = e52b4ae1321906cea08cc01cd78e147167e01491d09a481dbf867ce904de36dd
16 17
17pkgname = helmsman 18pkgname = helmsman
18
diff --git a/helmsman/PKGBUILD b/helmsman/PKGBUILD
index 048e58a..04fb0de 100644
--- a/helmsman/PKGBUILD
+++ b/helmsman/PKGBUILD
@@ -1,23 +1,25 @@
1# Maintainer: ml <ml@visu.li> 1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: ml <ml@visu.li>
2# to build in clean chroot build helm-diff from AUR, then pass to build cmd: 3# to build in clean chroot build helm-diff from AUR, then pass to build cmd:
3# $ extra-x86_64-build -- -I helm-diff-3.1.3-2-x86_64.pkg.tar.zst 4# $ extra-x86_64-build -- -I helm-diff-3.1.3-2-x86_64.pkg.tar.zst
5
4pkgname=helmsman 6pkgname=helmsman
5pkgver=3.6.3 7pkgver=3.15.1
6pkgrel=1 8pkgrel=1
7pkgdesc='Helm Charts as Code' 9pkgdesc='Helm Charts as Code'
8arch=('x86_64' 'i686') 10arch=('x86_64' 'i686')
9url='https://github.com/Praqma/helmsman' 11url='https://github.com/Praqma/helmsman'
10license=('MIT') 12license=('MIT')
11depends=('helm-diff' 'kubectl') 13depends=('helm' 'helm-diff' 'kubectl')
12optdepends=( 14optdepends=(
13 'ruby-hiera-eyaml: backend for secret encryption' 15 'ruby-hiera-eyaml: backend for secret encryption'
14 'helm-secrets: backend for secret encryption') 16 'helm-secrets: backend for secret encryption')
15makedepends=('go') 17makedepends=('go')
16source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz") 18source=("${pkgname}-${pkgver}.tar.gz::$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
17sha256sums=('05ce86066028ed0fbb99902018953107432727abe297745de4013815b5bf6781') 19sha256sums=('e52b4ae1321906cea08cc01cd78e147167e01491d09a481dbf867ce904de36dd')
18 20
19build() { 21build() {
20 cd "$pkgname-$pkgver" 22 cd "${pkgname}-${pkgver}"
21 export CGO_ENABLED=1 23 export CGO_ENABLED=1
22 export CGO_LDFLAGS="$LDFLAGS" 24 export CGO_LDFLAGS="$LDFLAGS"
23 export CGO_CFLAGS="$CFLAGS" 25 export CGO_CFLAGS="$CFLAGS"
@@ -26,18 +28,18 @@ build() {
26 export GOFLAGS='-buildmode=pie -modcacherw -mod=readonly -trimpath' 28 export GOFLAGS='-buildmode=pie -modcacherw -mod=readonly -trimpath'
27 # man makepkg(8), https://github.com/Praqma/helmsman/blob/master/Makefile 29 # man makepkg(8), https://github.com/Praqma/helmsman/blob/master/Makefile
28 TZ=UTC printf -v _date '%(%d%m%y)T' "${SOURCE_DATE_EPOCH:- -1}" 30 TZ=UTC printf -v _date '%(%d%m%y)T' "${SOURCE_DATE_EPOCH:- -1}"
29 go build -ldflags "-linkmode=external -X main.version=v$pkgver-$_date" ./cmd/helmsman 31 go build -ldflags "-linkmode=external -X main.version=v${pkgver}-${_date}" ./cmd/helmsman
30} 32}
31 33
32check() { 34check() {
33 cd "$pkgname-$pkgver" 35 cd "${pkgname}-${pkgver}"
34 go test -short ./... 36 go test -short ./...
35} 37}
36 38
37package() { 39package() {
38 cd "$pkgname-$pkgver" 40 cd "${pkgname}-${pkgver}"
39 install -Dm755 "$pkgname" -t "$pkgdir/usr/bin" 41 install -Dm755 "${pkgname}" -t "${pkgdir}/usr/bin"
40 install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname" 42 install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
41 43
42 # README, docs and examples 44 # README, docs and examples
43 install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname" 45 install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"