summaryrefslogtreecommitdiffstats
path: root/heisenbridge/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'heisenbridge/PKGBUILD')
-rw-r--r--heisenbridge/PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/heisenbridge/PKGBUILD b/heisenbridge/PKGBUILD
index c1bd9cf..2183544 100644
--- a/heisenbridge/PKGBUILD
+++ b/heisenbridge/PKGBUILD
@@ -1,16 +1,18 @@
1# Maintainer: Bjoern Franke <bjo+aur@schafweide.org> 1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Bjoern Franke <bjo+aur@schafweide.org>
3
2pkgname=heisenbridge 4pkgname=heisenbridge
3pkgver=1.13.1 5pkgver=1.14.0
4pkgrel=1 6pkgrel=1
5pkgdesc="a bouncer-style Matrix IRC bridge" 7pkgdesc="a bouncer-style Matrix IRC bridge"
6url="https://github.com/hifi/heisenbridge" 8url="https://github.com/hifi/heisenbridge"
7depends=('python' 'python-irc' 'python-ruamel-yaml' 'python-aiohttp-socks' 9depends=('python' 'python-irc' 'python-ruamel-yaml' 'python-aiohttp-socks'
8 'python-mautrix>=0.14.0' 'python-mautrix<0.17') 10 'python-mautrix')
9makedepends=('python-setuptools' 'python-pytest-runner') 11makedepends=('python-setuptools' 'python-pytest-runner')
10license=('MIT') 12license=('MIT')
11arch=('any') 13arch=('any')
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz" "${pkgname}.service" "${pkgname}.sysusers" "${pkgname}.tmpfiles") 14source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz" "${pkgname}.service" "${pkgname}.sysusers" "${pkgname}.tmpfiles")
13sha256sums=('92e561db62eba63a31899d6f697eb292ca2273beaf195c13132dab5c4101873e' 15sha256sums=('ba31d167982f022740abf1f785d32d959d9b35f64205d2f1e64d1d54e06f9b55'
14 '67487b221bff329952f5c95186c4ea794c7e7a3e25e6d213075fd306c68cfa95' 16 '67487b221bff329952f5c95186c4ea794c7e7a3e25e6d213075fd306c68cfa95'
15 'b3bc4328ead7afd186d5a191fabc347543c0fad17dc01047a4cf0532d999f255' 17 'b3bc4328ead7afd186d5a191fabc347543c0fad17dc01047a4cf0532d999f255'
16 '24bd23e4427aaf635a91b170c07abe8a6b1c62cbad47e50a161c12807641d351') 18 '24bd23e4427aaf635a91b170c07abe8a6b1c62cbad47e50a161c12807641d351')
@@ -18,11 +20,11 @@ backup=("etc/${pkgname}/registration.yaml")
18install="${pkgname}.install" 20install="${pkgname}.install"
19_dirname="${pkgname}-${pkgver}" 21_dirname="${pkgname}-${pkgver}"
20 22
21
22prepare() { 23prepare() {
23 cd "${srcdir}/${_dirname}" 24 cd "${srcdir}/${_dirname}"
24 # create an empty registration file so that permissions get written properly from the get go 25 # create an empty registration file so that permissions get written
25 # this way secret keys are never world readable 26 # properly from the get go this way secret keys are never world
27 # readable
26 touch registration.yaml 28 touch registration.yaml
27} 29}
28 30
@@ -38,8 +40,8 @@ package() {
38 40
39 python setup.py install --optimize=1 --skip-build --root="${pkgdir}/" --prefix="/usr" --install-data="${_shared_dir}" 41 python setup.py install --optimize=1 --skip-build --root="${pkgdir}/" --prefix="/usr" --install-data="${_shared_dir}"
40 42
41 # it's a semi-common failure for python packages to install tests in the main dir 43 # it's a semi-common failure for python packages to install tests in
42 # which would make them conflict eachother 44 # the main dir which would make them conflict eachother
43 rm -rf "${pkgdir}$(python -c 'import site; print(site.getsitepackages()[0])')/tests" 45 rm -rf "${pkgdir}$(python -c 'import site; print(site.getsitepackages()[0])')/tests"
44 46
45 install -Dvm 644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service" 47 install -Dvm 644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"