diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 51 |
1 files changed, 23 insertions, 28 deletions
@@ -1,4 +1,5 @@ | |||
1 | # Maintainer: Martin Thierer <thierer@web.de> | 1 | # Maintainer: maniacata <maniaciachao at gmail dot com> |
2 | # Contributor: Martin Thierer <thierer@web.de> | ||
2 | # Contributor: Amy Wilson <awils_1[at]xsmail[dot]com> | 3 | # Contributor: Amy Wilson <awils_1[at]xsmail[dot]com> |
3 | # Contributor: Simon Doppler <dopsi[at]dopsi[dot]ch> | 4 | # Contributor: Simon Doppler <dopsi[at]dopsi[dot]ch> |
4 | # Contributor: Agustin Borgna <hello[at]aborgna.com.ar> | 5 | # Contributor: Agustin Borgna <hello[at]aborgna.com.ar> |
@@ -6,45 +7,39 @@ | |||
6 | # Contributor: Renan Birck <renan.ee.ufsm at gmail.com> | 7 | # Contributor: Renan Birck <renan.ee.ufsm at gmail.com> |
7 | 8 | ||
8 | pkgname=logisim-evolution | 9 | pkgname=logisim-evolution |
9 | pkgver=2.15.0 | 10 | pkgver=3.3.4 |
10 | pkgrel=2 | 11 | pkgrel=1 |
11 | pkgdesc='An educational tool for designing and simulating digital logic circuits' | 12 | pkgdesc='An educational tool for designing and simulating digital logic circuits' |
12 | arch=('any') | 13 | arch=('any') |
13 | url="https://github.com/reds-heig/logisim-evolution" | 14 | url="https://github.com/reds-heig/logisim-evolution" |
14 | license=('GPL3') | 15 | license=('GPL3') |
15 | depends=('java-runtime=8' 'bash' 'hicolor-icon-theme') | 16 | depends=('java-runtime>=10' 'bash' 'hicolor-icon-theme') |
16 | makedepends=('java-environment-openjdk=8') | 17 | |
17 | 18 | source=("${pkgname}-${pkgver}.jar::https://github.com/reds-heig/logisim-evolution/releases/download/v${pkgver}/logisim-evolution-${pkgver}-all.jar" | |
18 | source=("${pkgname}-${pkgver}.tar.gz::https://github.com/reds-heig/logisim-evolution/archive/v${pkgver}.tar.gz" | 19 | "${pkgname}.desktop" |
19 | 'logisim-evolution.desktop' | 20 | "${pkgname}.sh" |
20 | 'logisim-evolution.sh' | 21 | "${pkgname}.xml") |
21 | 'logisim-evolution.xml') | 22 | sha256sums=('b04e666ed0b74126dfc8c2ce6ae0d425ad5bb39c2d77ef214158b6dfc67f8b0d' |
22 | sha256sums=('54c55415fce36801ed668c3bed64903444b0f6f3326091d63e84c253523fc8d8' | ||
23 | '086851b07012f669743080dc4f059cf7727b19200384070852b34e142533385b' | 23 | '086851b07012f669743080dc4f059cf7727b19200384070852b34e142533385b' |
24 | 'd5975cc0025905ab8a8a451ce4362ba876bed88008d3a5b2c0a7f664a85da1ba' | 24 | 'd5975cc0025905ab8a8a451ce4362ba876bed88008d3a5b2c0a7f664a85da1ba' |
25 | 'f90c3709748af806a33c14e81c8bf91dc06c3a4f58fe00cfe14a8f1842e09dec') | 25 | 'f90c3709748af806a33c14e81c8bf91dc06c3a4f58fe00cfe14a8f1842e09dec') |
26 | 26 | ||
27 | build() { | ||
28 | cd "$srcdir/${pkgname}-${pkgver}" | ||
29 | |||
30 | ./gradlew --no-daemon shadowJar | ||
31 | } | ||
32 | |||
33 | package() { | 27 | package() { |
34 | cd "$srcdir" | 28 | cd "$srcdir" |
35 | 29 | ||
36 | install -Dm644 "${pkgname}-${pkgver}/build/libs/${pkgname}-${pkgver}-all.jar" \ | 30 | jar xf ${pkgname}-${pkgver}.jar "resources/logisim/img/" |
37 | "${pkgdir}/usr/share/java/${pkgname}/${pkgname}.jar" | 31 | |
38 | install -Dm644 "${pkgname}.xml" \ | 32 | install -Dm644 ${pkgname}-${pkgver}.jar "${pkgdir}/usr/share/java/${pkgname}/${pkgname}.jar" |
39 | "${pkgdir}/usr/share/mime/packages/${pkgname}.xml" | 33 | install -Dm644 ${pkgname}.xml "${pkgdir}/usr/share/mime/packages/${pkgname}.xml" |
40 | install -Dm644 "${pkgname}.desktop" \ | 34 | install -Dm644 ${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop" |
41 | "${pkgdir}/usr/share/applications/logisim-evolution.desktop" | 35 | |
42 | for SIZE in 16 24 48 64 128; do | 36 | for SIZE in 16 20 24 48 64 128; do |
43 | install -Dm644 "${pkgname}-${pkgver}/src/main/resources/resources/logisim/img/logisim-icon-${SIZE}.png" \ | 37 | install -Dm644 "resources/logisim/img/logisim-icon-${SIZE}.png" \ |
44 | "${pkgdir}/usr/share/icons/hicolor/${SIZE}x${SIZE}/apps/logisim-evolution.png" | 38 | "${pkgdir}/usr/share/icons/hicolor/${SIZE}x${SIZE}/apps/${pkgname}.png" |
45 | done | 39 | done |
46 | install -Dm644 "${pkgname}-${pkgver}/src/main/resources/resources/logisim/img/logisim-icon.svg" \ | 40 | install -Dm644 "resources/logisim/img/logisim-icon.svg" \ |
47 | "${pkgdir}/usr/share/icons/hicolor/scalable/apps/logisim-evolution.svg" | 41 | "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg" |
42 | |||
48 | install -Dm755 "${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}" | 43 | install -Dm755 "${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}" |
49 | } | 44 | } |
50 | 45 | ||