diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 14 |
1 files changed, 3 insertions, 11 deletions
@@ -16,7 +16,7 @@ | |||
16 | pkgname=popcorntime-bin | 16 | pkgname=popcorntime-bin |
17 | _pkgname=popcorntime | 17 | _pkgname=popcorntime |
18 | pkgver=0.4.4 | 18 | pkgver=0.4.4 |
19 | pkgrel=1 | 19 | pkgrel=2 |
20 | pkgdesc="Stream free movies and TV shows from torrents" | 20 | pkgdesc="Stream free movies and TV shows from torrents" |
21 | arch=('x86_64') | 21 | arch=('x86_64') |
22 | url="https://popcorntime.app/" | 22 | url="https://popcorntime.app/" |
@@ -48,16 +48,8 @@ package() { | |||
48 | # Remove makepkg-created symlinks before copying content | 48 | # Remove makepkg-created symlinks before copying content |
49 | rm "$_zipfile" "${_pkgname}.desktop" | 49 | rm "$_zipfile" "${_pkgname}.desktop" |
50 | 50 | ||
51 | # Move library files to /usr/lib/popcorntime | 51 | # Copy complete content of source archive to /usr/share/${_pkgname} |
52 | install -d "${pkgdir}/usr/lib/${_pkgname}/${pkgver}" | 52 | cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}" |
53 | mv "${srcdir}"/lib/* "${pkgdir}/usr/lib/${_pkgname}/${pkgver}" | ||
54 | rmdir "${srcdir}"/lib | ||
55 | |||
56 | install -d "${pkgdir}/etc/ld.so.conf.d" | ||
57 | echo "/usr/lib/${_pkgname}/${pkgver}" > "${pkgdir}/etc/ld.so.conf.d/${_pkgname}.conf" | ||
58 | |||
59 | # Copy complete content of source archive to /usr/share/${_pkgname}/ | ||
60 | cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}/" | ||
61 | 53 | ||
62 | # Fix permissions | 54 | # Fix permissions |
63 | find "${pkgdir}/usr/share/${_pkgname}/" -perm 600 -exec chmod 644 '{}' \; | 55 | find "${pkgdir}/usr/share/${_pkgname}/" -perm 600 -exec chmod 644 '{}' \; |