aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 13 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5020cab..d645313 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,37 @@
1# Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/) 1# Maintainer : Yigit Sever <yigit at yigitsever dot com>
2# Contributor : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
2# Contributor : mickael9 <mickael9 at gmail dot com> 3# Contributor : mickael9 <mickael9 at gmail dot com>
3 4
4
5pkgname=wapiti 5pkgname=wapiti
6 6pkgver=3.1.3
7pkgver=3.1.2
8_name="$pkgname${pkgver:0:1}" 7_name="$pkgname${pkgver:0:1}"
9pkgrel=1 8pkgrel=1
10
11pkgdesc='Comprehensive web app vulnerability scanner written in Python' 9pkgdesc='Comprehensive web app vulnerability scanner written in Python'
12arch=('any') 10arch=('any')
13url="https://$pkgname-scanner.github.io" 11url="https://$pkgname-scanner.github.io"
14license=('GPL') 12license=('GPL')
15
16makedepends=('python-setuptools') 13makedepends=('python-setuptools')
17depends=('python' 'python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-yaswfp' 14depends=('python' 'python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-yaswfp'
18 'python-browser-cookie3' 'python-mako' 'python-python-socks' 'python-tld' 'python-httpx' 15 'python-browser-cookie3' 'python-mako' 'python-python-socks' 'python-tld' 'python-httpx'
19 'python-aiocache' 'python-sqlalchemy') 16 'python-aiocache' 'python-aiosqlite' 'python-sqlalchemy' 'python-loguru' 'python-cryptography')
20optdepends=('python-requests-kerberos: Kerberos authentication' 17optdepends=('python-requests-kerberos: Kerberos authentication'
21 'python-requests-ntlm: NTLM authentication') 18 'python-requests-ntlm: NTLM authentication')
22
23options=('zipman') 19options=('zipman')
24
25changelog=ChangeLog 20changelog=ChangeLog
26source=("https://github.com/$pkgname-scanner/$pkgname/releases/download/$pkgver/$_name-$pkgver.tar.gz") 21source=("https://github.com/$pkgname-scanner/$pkgname/releases/download/$pkgver/$_name-$pkgver.tar.gz")
27#source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$_name-$pkgver.tar.gz") 22sha256sums=('83ffef39199f92f530f7de7b47dbfb93ab2c9c97d3bbee93473084cba5796c61')
28sha256sums=('d10c51577792f949c9afa143043c9a25e6e86542cb48489d944ace45612aaea9')
29
30 23
31prepare() { rm -rf "$_name-$pkgver/tests"; } 24prepare() {
25 rm -rf "$_name-$pkgver/tests"
26}
32 27
33build() { 28build() {
34 cd "$_name-$pkgver" 29 cd "$_name-$pkgver"
30 sed -i '/mitmproxy==8.0.0/s/==8.0.0/>=8.0.0/' setup.py
31 sed -i '/dnspython==2.1.0/s/==2.1.0/>=2.1.0/' setup.py
32 sed -i '/cryptography==36.0.2/s/==36.0.2/>=36.0.2/' setup.py
33 sed -i '/browser-cookie3==0.11.4/s/==0.11.4/>=0.11.4/' setup.py
34 sed -i '/importlib_metadata==3.7.2/s/==3.7.2/>=3.7.2/' setup.py
35 python setup.py build 35 python setup.py build
36} 36}
37 37
@@ -39,6 +39,3 @@ package() {
39 cd "$_name-$pkgver" 39 cd "$_name-$pkgver"
40 PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build 40 PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
41} 41}
42
43
44# vim: ts=2 sw=2 et ft=PKGBUILD: