summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f9d93e..9ebaf3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,31 @@
4 4
5pkgname=wapiti 5pkgname=wapiti
6 6
7pkgver=3.0.3 7pkgver=3.0.4
8pkgrel=3 8pkgrel=1
9 9
10pkgdesc='A comprehensive web app vulnerability scanner written in Python' 10pkgdesc='A comprehensive web app vulnerability scanner written in Python'
11arch=('any') 11arch=('any')
12url='http://wapiti.sourceforge.net/' 12url="http://$pkgname.sourceforge.net"
13license=('GPL') 13license=('GPL')
14 14
15makedepends=('python-setuptools' 'python-pip')
15depends=('python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-tld' 16depends=('python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-tld'
16 'python-yaswfp' 'python-mako' 'python-pysocks') 17 'python-yaswfp' 'python-mako' 'python-pysocks')
17optdepends=('python-requests-kerberos: Kerberos authentication' 18optdepends=('python-requests-kerberos: Kerberos authentication'
18 'python-requests-ntlm: NTLM authentication') 19 'python-requests-ntlm: NTLM authentication')
19makedepends=('python-setuptools')
20 20
21options=('zipman') 21options=('zipman')
22 22
23changelog=ChangeLog 23changelog=ChangeLog
24source=("http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$pkgname${pkgver:0:1}-$pkgver.tar.gz") 24source=("http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$pkgname${pkgver:0:1}-$pkgver.tar.gz")
25sha256sums=('059f778453ebf05b38e9c6c837d3b3eb9b8921c8fdc6d4029df89f2b0e84f5b7') 25sha256sums=('8b696753a37506f0c3e8f542cb60e9f8198bb1bafd1a1dc97fbb9592becf31f3')
26 26
27 27
28prepare() {
29 rm -rf "$pkgname${pkgver:0:1}-$pkgver/tests"
30}
31
28build() { 32build() {
29 cd "$pkgname${pkgver:0:1}-$pkgver" 33 cd "$pkgname${pkgver:0:1}-$pkgver"
30 python setup.py build 34 python setup.py build