diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 14 |
1 files changed, 5 insertions, 9 deletions
@@ -2,21 +2,16 @@ | |||
2 | 2 | ||
3 | pkgname=unsilence | 3 | pkgname=unsilence |
4 | pkgver=1.0.5 | 4 | pkgver=1.0.5 |
5 | pkgrel=1 | 5 | pkgrel=2 |
6 | pkgdesc='Console Interface and Library to remove silent parts of a media file' | 6 | pkgdesc='Console Interface and Library to remove silent parts of a media file' |
7 | arch=('any') | 7 | arch=('any') |
8 | url='https://github.com/lagmoellertim/unsilence' | 8 | url='https://github.com/lagmoellertim/unsilence' |
9 | license=('MIT') | 9 | license=('MIT') |
10 | depends=('ffmpeg' 'python-argparse' 'python-rich') | 10 | depends=('ffmpeg' 'python' 'python-argparse' 'python-rich') |
11 | makedepends=('python-setuptools') | 11 | makedepends=('python-setuptools') |
12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") | 12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") |
13 | sha256sums=('326b85b8c58660962d2d7880e0e44dada2be2bdd9830dc0285cbee718d382ef7') | 13 | sha256sums=('326b85b8c58660962d2d7880e0e44dada2be2bdd9830dc0285cbee718d382ef7') |
14 | 14 | ||
15 | prepare() { | ||
16 | # https://github.com/lagmoellertim/unsilence/commit/30581844096967a736cc0ea8e17abb3dbd8f81ee | ||
17 | sed -i 's/ffmpeg version /ffmpeg version \\D\?/' "${pkgname}-${pkgver}/unsilence/lib/tools/ffmpeg_version.py" | ||
18 | } | ||
19 | |||
20 | build() { | 15 | build() { |
21 | cd "${pkgname}-${pkgver}" | 16 | cd "${pkgname}-${pkgver}" |
22 | python setup.py build | 17 | python setup.py build |
@@ -25,8 +20,9 @@ build() { | |||
25 | package() { | 20 | package() { |
26 | cd "${pkgname}-${pkgver}" | 21 | cd "${pkgname}-${pkgver}" |
27 | python setup.py install --root="${pkgdir}" --optimize=1 --skip-build | 22 | python setup.py install --root="${pkgdir}" --optimize=1 --skip-build |
28 | install -Dm644 'README.md' "${pkgdir}/usr/share/doc/${pkgname}/README.md" | 23 | install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md' |
29 | install -Dm644 'LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" | 24 | install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE' |
25 | rm -r "${pkgdir}/usr/lib/python"*'/site-packages/examples' | ||
30 | } | 26 | } |
31 | 27 | ||
32 | # vim: ts=2 sw=2 et: | 28 | # vim: ts=2 sw=2 et: |