summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1244e02..d038984 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,16 @@
2 2
3pkgname=unsilence 3pkgname=unsilence
4pkgver=1.0.5 4pkgver=1.0.5
5pkgrel=1 5pkgrel=2
6pkgdesc='Console Interface and Library to remove silent parts of a media file' 6pkgdesc='Console Interface and Library to remove silent parts of a media file'
7arch=('any') 7arch=('any')
8url='https://github.com/lagmoellertim/unsilence' 8url='https://github.com/lagmoellertim/unsilence'
9license=('MIT') 9license=('MIT')
10depends=('ffmpeg' 'python-argparse' 'python-rich') 10depends=('ffmpeg' 'python' 'python-argparse' 'python-rich')
11makedepends=('python-setuptools') 11makedepends=('python-setuptools')
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") 12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
13sha256sums=('326b85b8c58660962d2d7880e0e44dada2be2bdd9830dc0285cbee718d382ef7') 13sha256sums=('326b85b8c58660962d2d7880e0e44dada2be2bdd9830dc0285cbee718d382ef7')
14 14
15prepare() {
16 # https://github.com/lagmoellertim/unsilence/commit/30581844096967a736cc0ea8e17abb3dbd8f81ee
17 sed -i 's/ffmpeg version /ffmpeg version \\D\?/' "${pkgname}-${pkgver}/unsilence/lib/tools/ffmpeg_version.py"
18}
19
20build() { 15build() {
21 cd "${pkgname}-${pkgver}" 16 cd "${pkgname}-${pkgver}"
22 python setup.py build 17 python setup.py build
@@ -25,8 +20,9 @@ build() {
25package() { 20package() {
26 cd "${pkgname}-${pkgver}" 21 cd "${pkgname}-${pkgver}"
27 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build 22 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
28 install -Dm644 'README.md' "${pkgdir}/usr/share/doc/${pkgname}/README.md" 23 install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
29 install -Dm644 'LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" 24 install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
25 rm -r "${pkgdir}/usr/lib/python"*'/site-packages/examples'
30} 26}
31 27
32# vim: ts=2 sw=2 et: 28# vim: ts=2 sw=2 et: