diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 35 |
1 files changed, 14 insertions, 21 deletions
@@ -1,4 +1,5 @@ | |||
1 | # Maintainer: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com> | 1 | # Maintainer: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com> |
2 | # Contributor: Bastien Traverse <firstname at lastname dot email> | ||
2 | # Contributor: Ricardo Funke <ricardo [at] gmail [dot] com> | 3 | # Contributor: Ricardo Funke <ricardo [at] gmail [dot] com> |
3 | # Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu> | 4 | # Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu> |
4 | # Contributor: Iwan Timmer <irtimmer [at] gmail [dot] com> | 5 | # Contributor: Iwan Timmer <irtimmer [at] gmail [dot] com> |
@@ -12,8 +13,8 @@ | |||
12 | 13 | ||
13 | pkgname=popcorntime-bin | 14 | pkgname=popcorntime-bin |
14 | _pkgname=popcorntime | 15 | _pkgname=popcorntime |
15 | pkgver=0.3.9 | 16 | pkgver=0.3.10 |
16 | pkgrel=7 | 17 | pkgrel=1 |
17 | pkgdesc="Stream movies and TV shows from torrents" | 18 | pkgdesc="Stream movies and TV shows from torrents" |
18 | arch=('i686' 'x86_64') | 19 | arch=('i686' 'x86_64') |
19 | url="https://popcorntime.sh" | 20 | url="https://popcorntime.sh" |
@@ -23,29 +24,16 @@ provides=('popcorntime' 'popcorn-time-ce') | |||
23 | conflicts=('popcorntime') | 24 | conflicts=('popcorntime') |
24 | options=('!strip') | 25 | options=('!strip') |
25 | source=("${_pkgname}.desktop") | 26 | source=("${_pkgname}.desktop") |
26 | source_i686=("https://get.popcorntime.sh/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz") | 27 | source_i686=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz") |
27 | source_x86_64=("https://get.popcorntime.sh/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz") | 28 | source_x86_64=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz") |
28 | sha256sums=('4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334') | 29 | sha256sums=('4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334') |
29 | sha256sums_i686=('0c8a84e853946c70b4986d8044ec869f995b8001b48cd5bd3ef0ed61e8848335') | 30 | sha256sums_i686=('c6497b067304918c3d19db2fecd36cc9efe1fff13765d461b24fd2cd8692ed42') |
30 | sha256sums_x86_64=('5655111b7f5883ce7a620a8fb0b9f7fb7563a46516697aac5ad2b28b8b5e49df') | 31 | sha256sums_x86_64=('b7f789c2e2f3b0f7e3408a437080404f8a2aa7ce4a41858cf891b02cda8c37a5') |
31 | |||
32 | [ "$CARCH" = "i686" ] && _platform=linux32 | ||
33 | [ "$CARCH" = "x86_64" ] && _platform=linux64 | ||
34 | 32 | ||
35 | package() { | 33 | package() { |
36 | _bpath="${_platform}" | ||
37 | |||
38 | install -dm755 "${pkgdir}/usr/share/${_pkgname}" | 34 | install -dm755 "${pkgdir}/usr/share/${_pkgname}" |
39 | install -dm755 "${pkgdir}/usr/bin" | 35 | install -dm755 "${pkgdir}/usr/bin" |
40 | 36 | ||
41 | # Program | ||
42 | install -Dm755 "${_bpath}/Popcorn-Time" "${pkgdir}/usr/share/${_pkgname}/" | ||
43 | install -Dm644 "${_bpath}/"{icudtl.dat,libffmpegsumo.so,nw.pak,package.json} \ | ||
44 | "${pkgdir}/usr/share/${_pkgname}/" | ||
45 | |||
46 | # Directories | ||
47 | cp -a "${_bpath}/"{locales,node_modules,src} "${pkgdir}/usr/share/${_pkgname}/" | ||
48 | |||
49 | # Link to program | 37 | # Link to program |
50 | ln -s "/usr/share/${_pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgname}" | 38 | ln -s "/usr/share/${_pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgname}" |
51 | 39 | ||
@@ -53,6 +41,11 @@ package() { | |||
53 | install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop" | 41 | install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop" |
54 | 42 | ||
55 | # Icon | 43 | # Icon |
56 | install -Dm644 "${_bpath}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png" | 44 | install -Dm644 "${srcdir}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png" |
57 | } | 45 | |
46 | # Remove makepkg-created symlinks before copying content | ||
47 | rm *.tar.xz *.desktop | ||
58 | 48 | ||
49 | # Copy complete content of source archive to /usr/share/${_pkgname}/ | ||
50 | cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}/" | ||
51 | } | ||