summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 27 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69feb57..96fe647 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,32 +9,31 @@
9# Contributor: xantares <xantares09 [at] hotmail [dot] com> 9# Contributor: xantares <xantares09 [at] hotmail [dot] com>
10 10
11pkgname=popcorntime-bin 11pkgname=popcorntime-bin
12pkgver=0.3.7.2 12pkgver=0.3.8.0
13pkgrel=6 13_pkgver='0.3.8-0'
14pkgrel=1
14pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch." 15pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch."
15arch=('x86_64' 'i686') 16arch=('x86_64' 'i686')
16url="http://popcorntime.io/" 17url="http://popcorntime.io/"
17license=('GPL3') 18license=('GPL3')
18depends=('ttf-liberation' 'gconf' 'nss' 'libxtst' 'gtk2' 'alsa-lib') 19depends=('libsystemd' 'ttf-liberation' 'gconf' 'nss' 'libxtst' 'gtk2' 'alsa-lib')
19optdepends=('net-tools: necessary for the new vpn feature') 20optdepends=('net-tools: necessary for the new vpn feature')
20provides=('popcorntime') 21provides=('popcorntime')
21conflicts=('popcorntime') 22conflicts=('popcorntime')
22options=('!strip') 23options=('!strip')
23install="popcorntime.install" 24install="popcorntime.install"
24sha256sums=('0b294d08e6bc46d3d06717d4a6344b4e6e4e14f742f61101b8498d931d99a952' 25sha1sums=('e0d34c48fb55680f922b62d31121032c744fb183'
25 '9e1bc552bb06446689233b1a123d4cc421771673a7b803a980d4149bf4dc38b3' 26 '23ee4387bebeaec41fb5b2d0428dd0ff5d0cad73'
26 '3dd794302ad0b3a98d48973175b6de9bc632181872df2d0376a19a5cc0aa14a2' 27 '98cba5c0c979d37e601cc33cf3b562f106427d36')
27 'ac2b7183d3ea62ae821c7d1f4b243b0ca41c7838efa16babe29cad0c4958ee25')
28 28
29_platform=Linux64 29_platform='Linux-64'
30 30
31if [ "$CARCH" = 'i686' ]; then 31if [ "$CARCH" = 'i686' ]; then
32 _platform=Linux32 32 _platform='Linuxi-32'
33 sha256sums[0]='21e5dbc667f13572fcd8edc535ce4fcd2c0bffafcd237753ad8a2f1cc665e1b7' 33 sha256sums[0]='0217ce93e88650c7d557cafcfdf10a4b5fa14c54'
34fi 34fi
35 35
36source=("http://get.popcorntime.io/build/Popcorn-Time-${pkgver}-${_platform}.tar.xz" 36source=("http://get.popcorntime.io/build/Popcorn-Time-${_pkgver}-${_platform}.tar.xz"
37 "icon.png"
38 "popcorntime.install" 37 "popcorntime.install"
39 "popcorntime.desktop") 38 "popcorntime.desktop")
40 39
@@ -47,10 +46,21 @@ package() {
47 46
48 # Program 47 # Program
49 echo "${pkgdir}/opt/${pkgname}/" 48 echo "${pkgdir}/opt/${pkgname}/"
50 install -Dm755 ${srcdir}/Popcorn-Time "${pkgdir}/opt/${pkgname}/" 49 install -Dm755 "${srcdir}/Popcorn-Time" "${pkgdir}/opt/${pkgname}/"
51 install -Dm644 ${srcdir}/nw.pak "${pkgdir}/opt/${pkgname}/" 50 install -Dm644 "${srcdir}/nw.pak" "${pkgdir}/opt/${pkgname}/"
52 install -Dm644 ${srcdir}/libffmpegsumo.so "${pkgdir}/opt/${pkgname}/" 51 install -Dm644 "${srcdir}/libffmpegsumo.so" "${pkgdir}/opt/${pkgname}/"
53 install -Dm644 ${srcdir}/package.nw "${pkgdir}/opt/${pkgname}/" 52 install -Dm644 "${srcdir}/CHANGELOG.md" "${pkgdir}/opt/${pkgname}/"
53 install -Dm644 "${srcdir}/icudtl.dat" "${pkgdir}/opt/${pkgname}/"
54 install -Dm644 "${srcdir}/install" "${pkgdir}/opt/${pkgname}/"
55 install -Dm644 "${srcdir}/LICENSE.txt" "${pkgdir}/opt/${pkgname}/"
56 install -Dm644 "${srcdir}/package.json" "${pkgdir}/opt/${pkgname}/"
57 install -Dm644 "${srcdir}/popcorntime.png" "${pkgdir}/opt/${pkgname}/"
58 install -Dm644 "${srcdir}/README.md" "${pkgdir}/opt/${pkgname}/"
59
60 # Directories
61 cp -a "${srcdir}/locales" "${pkgdir}/opt/${pkgname}/"
62 cp -a "${srcdir}/node_modules" "${pkgdir}/opt/${pkgname}/"
63 cp -a "${srcdir}/src" "${pkgdir}/opt/${pkgname}/"
54 64
55 # Link to program 65 # Link to program
56 ln -s "/opt/${pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/popcorntime" 66 ln -s "/opt/${pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/popcorntime"
@@ -59,5 +69,5 @@ package() {
59 install -Dm644 "${srcdir}/popcorntime.desktop" "${pkgdir}/usr/share/applications/popcorntime.desktop" 69 install -Dm644 "${srcdir}/popcorntime.desktop" "${pkgdir}/usr/share/applications/popcorntime.desktop"
60 70
61 # Icon 71 # Icon
62 install -Dm644 "${srcdir}/icon.png" "${pkgdir}/usr/share/pixmaps/popcorntime.png" 72 install -Dm644 "${srcdir}/popcorntime.png" "${pkgdir}/usr/share/pixmaps/popcorntime.png"
63} 73}