summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..b8be4c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
1# This is an example PKGBUILD file. Use this as a start to creating your own,
2# and remove these comments. For more information, see 'man PKGBUILD'.
3# NOTE: Please fill out the license field for your package! If it is unknown,
4# then please put 'unknown'.
5
6# Maintainer: Kuklin István <kuklinistvan@zoho.com>
7pkgname=anki-official-binary-bundle
8pkgver=2.1.9
9pkgrel=1
10epoch=
11pkgdesc="The official binary shipped with the tested versions of the dependent libraries."
12arch=('x86_64')
13url="https://apps.ankiweb.net"
14license=('GNU AGPL')
15groups=()
16depends=()
17makedepends=()
18checkdepends=()
19optdepends=()
20provides=('anki')
21conflicts=('anki-git')
22replaces=()
23backup=()
24options=()
25install=
26changelog=
27topdirname="anki-$pkgver-linux-amd64"
28source=("https://apps.ankiweb.net/downloads/current/${topdirname}.tar.bz2" "remove_xdg_cmds_from_makefile.patch")
29noextract=()
30md5sums=('8cc5bb80efc5dac2e9dc9ee802924e24' 'a7e473f132a4fecd9cb77ac9c8530f5f')
31validpgpkeys=()
32
33prepare() {
34 cd "$srcdir"
35 patch -p0 -i remove_xdg_cmds_from_makefile.patch
36}
37
38build() {
39 cd "$topdirname"
40 make
41}
42
43# check() {
44# cd "$topdirname"
45# make -k check
46# }
47
48package() {
49 cd "$topdirname"
50 make PREFIX="$pkgdir/usr" install
51}