diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 51 |
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD new file mode 100644 index 0000000..b8be4c2 --- /dev/null +++ b/PKGBUILD | |||
@@ -0,0 +1,51 @@ | |||
1 | # This is an example PKGBUILD file. Use this as a start to creating your own, | ||
2 | # and remove these comments. For more information, see 'man PKGBUILD'. | ||
3 | # NOTE: Please fill out the license field for your package! If it is unknown, | ||
4 | # then please put 'unknown'. | ||
5 | |||
6 | # Maintainer: Kuklin István <kuklinistvan@zoho.com> | ||
7 | pkgname=anki-official-binary-bundle | ||
8 | pkgver=2.1.9 | ||
9 | pkgrel=1 | ||
10 | epoch= | ||
11 | pkgdesc="The official binary shipped with the tested versions of the dependent libraries." | ||
12 | arch=('x86_64') | ||
13 | url="https://apps.ankiweb.net" | ||
14 | license=('GNU AGPL') | ||
15 | groups=() | ||
16 | depends=() | ||
17 | makedepends=() | ||
18 | checkdepends=() | ||
19 | optdepends=() | ||
20 | provides=('anki') | ||
21 | conflicts=('anki-git') | ||
22 | replaces=() | ||
23 | backup=() | ||
24 | options=() | ||
25 | install= | ||
26 | changelog= | ||
27 | topdirname="anki-$pkgver-linux-amd64" | ||
28 | source=("https://apps.ankiweb.net/downloads/current/${topdirname}.tar.bz2" "remove_xdg_cmds_from_makefile.patch") | ||
29 | noextract=() | ||
30 | md5sums=('8cc5bb80efc5dac2e9dc9ee802924e24' 'a7e473f132a4fecd9cb77ac9c8530f5f') | ||
31 | validpgpkeys=() | ||
32 | |||
33 | prepare() { | ||
34 | cd "$srcdir" | ||
35 | patch -p0 -i remove_xdg_cmds_from_makefile.patch | ||
36 | } | ||
37 | |||
38 | build() { | ||
39 | cd "$topdirname" | ||
40 | make | ||
41 | } | ||
42 | |||
43 | # check() { | ||
44 | # cd "$topdirname" | ||
45 | # make -k check | ||
46 | # } | ||
47 | |||
48 | package() { | ||
49 | cd "$topdirname" | ||
50 | make PREFIX="$pkgdir/usr" install | ||
51 | } | ||