diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 12 |
1 files changed, 6 insertions, 6 deletions
@@ -3,7 +3,8 @@ | |||
3 | 3 | ||
4 | 4 | ||
5 | pkgname=anki-official-binary-bundle | 5 | pkgname=anki-official-binary-bundle |
6 | pkgver=2.1.58 | 6 | pkgver=2.1.60 |
7 | _pkgname="anki-$pkgver-linux-qt6" | ||
7 | pkgrel=1 | 8 | pkgrel=1 |
8 | epoch= | 9 | epoch= |
9 | pkgdesc="The official binary shipped with the tested versions of the dependent libraries." | 10 | pkgdesc="The official binary shipped with the tested versions of the dependent libraries." |
@@ -19,18 +20,17 @@ conflicts=('anki' 'anki-bin' 'anki-git') | |||
19 | replaces=() | 20 | replaces=() |
20 | options=() | 21 | options=() |
21 | install=$pkgname.install | 22 | install=$pkgname.install |
22 | source=("https://github.com/ankitects/anki/releases/download/${pkgver}/${topdirname}.tar.zst" | 23 | source=("https://github.com/ankitects/anki/releases/download/${pkgver}/${_pkgname}.tar.zst" |
23 | "install_sh.patch") | 24 | "install_sh.patch") |
24 | sha256sums=('f6b94d4a16dda2c09aeb47f8265842d78765de3d83c6a16bdc680e38c59d5c56' | 25 | sha256sums=('21780854c71a6414dab11b5e673ded45a0d0dabb167a5d9c3689dd2b6567cd35' |
25 | '991297cb02434d753f55980205a22971ed98655b0f62f0104ae4692155355d8c') | 26 | '991297cb02434d753f55980205a22971ed98655b0f62f0104ae4692155355d8c') |
26 | 27 | ||
27 | topdirname="anki-$pkgver-linux-qt6" | ||
28 | prepare() { | 28 | prepare() { |
29 | cd "$srcdir/$topdirname" | 29 | cd "$srcdir/$_pkgname" |
30 | patch install.sh ../install_sh.patch | 30 | patch install.sh ../install_sh.patch |
31 | } | 31 | } |
32 | 32 | ||
33 | package() { | 33 | package() { |
34 | cd "$topdirname" | 34 | cd "$_pkgname" |
35 | PREFIX="$pkgdir/usr/" ./install.sh | 35 | PREFIX="$pkgdir/usr/" ./install.sh |
36 | } | 36 | } |