summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8059a00..db95a56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
2 2
3pkgname='gourmand' 3pkgname='gourmand'
4pkgver=1.0.0 4pkgver=1.0.0
5pkgrel=1 5pkgrel=2
6pkgdesc="A recipe manager for desktop that can import recipes" 6pkgdesc="A recipe manager for desktop that can import recipes"
7arch=('any') 7arch=('any')
8url="https://github.com/GourmandRecipeManager/gourmand" 8url="https://github.com/GourmandRecipeManager/gourmand"
9license=('GPL') 9license=('GPL')
10depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy' 'python-lxml' 'python-cairo' 'python-requests') 10depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy' 'python-lxml' 'python-cairo' 'python-requests')
11makedepends=('python-pip') 11makedepends=('python-pip' 'gendesk')
12checkdepends=() 12checkdepends=()
13optdepends=( 13optdepends=(
14 'python-beautifulsoup4: Webpage import plugin' 14 'python-beautifulsoup4: Webpage import plugin'
@@ -23,7 +23,12 @@ conflicts=('gourmet')
23source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl") 23source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl")
24sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4') 24sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4')
25 25
26prepare() {
27 gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc"
28}
29
26package() { 30package() {
27 # https://wiki.archlinux.org/title/Python_package_guidelines#pip 31 # https://wiki.archlinux.org/title/Python_package_guidelines#pip
28 PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl 32 PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
33 install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
29} 34}