diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 9 |
1 files changed, 7 insertions, 2 deletions
@@ -2,13 +2,13 @@ | |||
2 | 2 | ||
3 | pkgname='gourmand' | 3 | pkgname='gourmand' |
4 | pkgver=1.0.0 | 4 | pkgver=1.0.0 |
5 | pkgrel=1 | 5 | pkgrel=2 |
6 | pkgdesc="A recipe manager for desktop that can import recipes" | 6 | pkgdesc="A recipe manager for desktop that can import recipes" |
7 | arch=('any') | 7 | arch=('any') |
8 | url="https://github.com/GourmandRecipeManager/gourmand" | 8 | url="https://github.com/GourmandRecipeManager/gourmand" |
9 | license=('GPL') | 9 | license=('GPL') |
10 | depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy' 'python-lxml' 'python-cairo' 'python-requests') | 10 | depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy' 'python-lxml' 'python-cairo' 'python-requests') |
11 | makedepends=('python-pip') | 11 | makedepends=('python-pip' 'gendesk') |
12 | checkdepends=() | 12 | checkdepends=() |
13 | optdepends=( | 13 | optdepends=( |
14 | 'python-beautifulsoup4: Webpage import plugin' | 14 | 'python-beautifulsoup4: Webpage import plugin' |
@@ -23,7 +23,12 @@ conflicts=('gourmet') | |||
23 | source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl") | 23 | source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl") |
24 | sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4') | 24 | sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4') |
25 | 25 | ||
26 | prepare() { | ||
27 | gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" | ||
28 | } | ||
29 | |||
26 | package() { | 30 | package() { |
27 | # https://wiki.archlinux.org/title/Python_package_guidelines#pip | 31 | # https://wiki.archlinux.org/title/Python_package_guidelines#pip |
28 | PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl | 32 | PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl |
33 | install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop" | ||
29 | } | 34 | } |