summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 0000000..06d5178
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
1pkgbase = httpx-bin
2 pkgdesc = Fast and multi-purpose HTTP toolkit
3 pkgver = 1.0.3
4 pkgrel = 1
5 url = https://github.com/projectdiscovery/httpx
6 arch = x86_64
7 arch = armv6h
8 arch = aarch64
9 license = MIT
10 provides = httpx
11 conflicts = httpx
12 source_x86_64 = httpx-1.0.3-x86_64.tar.gz::https://github.com/projectdiscovery/httpx/releases/download/v1.0.3/httpx_1.0.3_linux_amd64.tar.gz
13 sha256sums_x86_64 = 5cd5dba56a84d2acedb47f93272770dec0a1cf3020597bc83fbf0e3655b220b8
14 source_armv6h = httpx-1.0.3-armv6.tar.gz::https://github.com/projectdiscovery/httpx/releases/download/v1.0.3/httpx_1.0.3_linux_armv6.tar.gz
15 sha256sums_armv6h = cbdfa4b4862ec772bd70c5af60dc22df705e7c95c18b618444f628f747af0fb0
16 source_aarch64 = httpx-1.0.3-aarch64.tar.gz::https://github.com/projectdiscovery/httpx/releases/download/v1.0.3/httpx_1.0.3_linux_arm64.tar.gz
17 sha256sums_aarch64 = 4fde28ba2328e0f49ea301a7e1ab16b5fc2ae1545fa8a3a71b0aaea19e8fe651
18
19pkgname = httpx-bin
20
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..623d0e7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
1*
2!.gitignore
3!.SRCINFO
4!PKGBUILD
5
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..56e5e22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
1# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
2
3_pkgname='httpx'
4pkgname="${_pkgname}-bin"
5pkgver=1.0.3
6pkgrel=1
7pkgdesc='Fast and multi-purpose HTTP toolkit'
8arch=('x86_64' 'armv6h' 'aarch64')
9url='https://github.com/projectdiscovery/httpx'
10license=('MIT')
11provides=("${_pkgname}")
12conflicts=("${_pkgname}")
13
14source_x86_64=("${_pkgname}-${pkgver}-x86_64.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.tar.gz")
15source_armv6h=("${_pkgname}-${pkgver}-armv6.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_armv6.tar.gz")
16source_aarch64=("${_pkgname}-${pkgver}-aarch64.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.tar.gz")
17
18sha256sums_x86_64=('5cd5dba56a84d2acedb47f93272770dec0a1cf3020597bc83fbf0e3655b220b8')
19sha256sums_armv6h=('cbdfa4b4862ec772bd70c5af60dc22df705e7c95c18b618444f628f747af0fb0')
20sha256sums_aarch64=('4fde28ba2328e0f49ea301a7e1ab16b5fc2ae1545fa8a3a71b0aaea19e8fe651')
21
22package() {
23 install -Dvm755 "${_pkgname}" -t "${pkgdir}/usr/bin"
24 install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}"
25 install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
26}
27
28# vim: ts=2 sw=2 et: