summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 0000000..e551162
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
1pkgbase = ryokucha
2 pkgdesc = A GTK4 library that includes customized widgets
3 pkgver = 0.1.0
4 pkgrel = 1
5 url = https://github.com/ryonakano/ryokucha
6 arch = x86_64
7 license = LGPL3
8 makedepends = meson
9 makedepends = vala
10 depends = gtk4
11 depends = pango
12 source = ryokucha-0.1.0.tar.gz::https://github.com/ryonakano/ryokucha/archive/0.1.0.tar.gz
13 sha256sums = 89b9492b33498f46c4f4dd79ef3cbf526069a5422439766382ffdcd0ba1da159
14
15pkgname = ryokucha
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..ef4fac9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
1# Maintainer: Yigit Sever <yigit@yigitsever.com>
2
3pkgname=ryokucha
4pkgver=0.1.0
5pkgrel=1
6pkgdesc="A GTK4 library that includes customized widgets"
7arch=('x86_64')
8url="https://github.com/ryonakano/ryokucha"
9license=('LGPL3')
10depends=('gtk4' 'pango')
11makedepends=('meson' 'vala')
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
13sha256sums=('89b9492b33498f46c4f4dd79ef3cbf526069a5422439766382ffdcd0ba1da159')
14
15build() {
16 arch-meson ${pkgname}-${pkgver} build
17 meson compile -C build
18}
19
20package() {
21 meson install -C build --destdir "${pkgdir}"
22}