summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--htpdate.service10
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 0000000..5330a12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
1pkgbase = htpdate
2 pkgdesc = A client for time synchronisation
3 pkgver = 1.1.1
4 pkgrel = 1
5 url = http://www.vervest.org/htp/
6 arch = i686
7 arch = x86_64
8 license = GPL2
9 depends = glibc
10 source = http://www.vervest.org/htp/archive/c/htpdate-1.1.1.tar.xz
11 source = htpdate.service
12 md5sums = c612f63282e3f23b709f37a5c81d4739
13 md5sums = b419153625904d9a5544e585f69c66c5
14
15pkgname = htpdate
16
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..8ff331e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
1# Contributor: Jonathan Ryan <jryan@curious-computing.com>
2# Contributor: Hussam Al-Tayeb <hussam@visp.net.lb>
3pkgname=htpdate
4pkgver=1.1.1
5pkgrel=1
6pkgdesc="A client for time synchronisation"
7arch=(i686 x86_64)
8url="http://www.vervest.org/htp/"
9license=(GPL2)
10depends=('glibc')
11source=("http://www.vervest.org/htp/archive/c/${pkgname}-${pkgver}.tar.xz" "htpdate.service")
12md5sums=('c612f63282e3f23b709f37a5c81d4739'
13 'b419153625904d9a5544e585f69c66c5')
14build() {
15 cd ${pkgname}-${pkgver}
16 make
17}
18package() {
19 install -D -m 644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service
20 cd ${pkgname}-${pkgver}
21 install -D -m 755 htpdate ${pkgdir}/usr/bin/htpdate
22 install -D -m 644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8
23}
24
diff --git a/htpdate.service b/htpdate.service
new file mode 100644
index 0000000..831f411
--- /dev/null
+++ b/htpdate.service
@@ -0,0 +1,10 @@
1[Unit]
2Description=Htpdate Daemon
3
4[Service]
5Type=forking
6PIDFile=/run/htpdate.pid
7ExecStart=/usr/bin/htpdate -D -s -i /run/htpdate.pid www.linux.org www.freebsd.org
8
9[Install]
10WantedBy=multi-user.target \ No newline at end of file