summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--ChangeLog26
-rw-r--r--PKGBUILD6
3 files changed, 32 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0dca96..183efd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
1pkgbase = wapiti 1pkgbase = wapiti
2 pkgdesc = Comprehensive web app vulnerability scanner written in Python 2 pkgdesc = Comprehensive web app vulnerability scanner written in Python
3 pkgver = 3.0.8 3 pkgver = 3.0.9
4 pkgrel = 3 4 pkgrel = 1
5 url = https://wapiti.sourceforge.net 5 url = https://wapiti.sourceforge.net
6 changelog = ChangeLog 6 changelog = ChangeLog
7 arch = any 7 arch = any
@@ -23,7 +23,7 @@ pkgbase = wapiti
23 optdepends = python-requests-kerberos: Kerberos authentication 23 optdepends = python-requests-kerberos: Kerberos authentication
24 optdepends = python-requests-ntlm: NTLM authentication 24 optdepends = python-requests-ntlm: NTLM authentication
25 options = zipman 25 options = zipman
26 source = https://downloads.sourceforge.net/sourceforge/wapiti/wapiti/wapiti-3.0.8/wapiti3-3.0.8.tar.gz 26 source = https://downloads.sourceforge.net/sourceforge/wapiti/wapiti/wapiti-3.0.9/wapiti3-3.0.9.tar.gz
27 sha256sums = 110d825ec7c2ba6a063398d63c1939d893f219fee6b5444c643f4b1cd9c71441 27 sha256sums = bd64674b9152057bf1534ca7d7aab8cad4fccb1027813e0d0281f48823a82475
28 28
29pkgname = wapiti 29pkgname = wapiti
diff --git a/ChangeLog b/ChangeLog
index a33ccec..46734c7 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,28 @@
115/02/2021
2 Wapiti 3.0.9
3 CLI: New "passive" module option allows to use less aggressives modules only
4 WP_ENUM: Improve detection of Wordpress
5 SSL: New module to check TLS/SSL configuration, powered by SSLyze
6 Log4Shell: New attack module to detect the infamous vulnerability
7
818/11/2021
9 Wapiti 3.0.8
10 CLI: prevent users from using -a without specifying --ayth-type (and vice versa)
11 Crawler: Upgrade HTTP related dependencies (httpx, httpcore, httpx-socks)
12
1314/10/2021
14 Wapiti 3.0.7
15 Crawler: Extract URLs from AngularJS based websites
16 Crawler: Support HTTP responses compressed with Brotli
17 Crawler: Fix handling of upload forms (due to moving to httpx), handling of button fields having a value
18 CLI: Added option to log output to a file
19 Modules: Increased speed of modules Nikto, buster, drupal_enum, brute_login_form thank to concurrency
20 Modules: Added a module to detect subdomain takeovers
21 XSS: Removed references to wapiti3.ovh for XSS payloads
22 Modules: Fixed some false positives in modules backup, Nikto and SQL
23 Modules: Upgrade Wappalyzer module
24 Crawler: Upgrade HTTP related dependencies (httpx, httpcore)
25
113/05/2021 2613/05/2021
2 Wapiti 3.0.5 27 Wapiti 3.0.5
3 SQL: boolean based blind SQL injection support added 28 SQL: boolean based blind SQL injection support added
@@ -9,7 +34,6 @@
9 Fingerprinting: several issues fixed on mod_wapp 34 Fingerprinting: several issues fixed on mod_wapp
10 Crawler: HTTP requests are processed concurrently for faster crawling. Check the new --tasks option. 35 Crawler: HTTP requests are processed concurrently for faster crawling. Check the new --tasks option.
11 36
12
1320/02/2021 3720/02/2021
14 Wapiti 3.0.4 38 Wapiti 3.0.4
15 XSS: improved context awareness of HTML webpage, payloads can now use the existing HTML tags without closing them 39 XSS: improved context awareness of HTML webpage, payloads can now use the existing HTML tags without closing them
diff --git a/PKGBUILD b/PKGBUILD
index 6747523..f28ef05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
4 4
5pkgname=wapiti 5pkgname=wapiti
6 6
7pkgver=3.0.8 7pkgver=3.0.9
8_name="$pkgname${pkgver:0:1}" 8_name="$pkgname${pkgver:0:1}"
9pkgrel=3 9pkgrel=1
10 10
11pkgdesc='Comprehensive web app vulnerability scanner written in Python' 11pkgdesc='Comprehensive web app vulnerability scanner written in Python'
12arch=('any') 12arch=('any')
@@ -24,7 +24,7 @@ options=('zipman')
24 24
25changelog=ChangeLog 25changelog=ChangeLog
26source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$_name-$pkgver.tar.gz") 26source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$_name-$pkgver.tar.gz")
27sha256sums=('110d825ec7c2ba6a063398d63c1939d893f219fee6b5444c643f4b1cd9c71441') 27sha256sums=('bd64674b9152057bf1534ca7d7aab8cad4fccb1027813e0d0281f48823a82475')
28 28
29 29
30prepare() { rm -rf "$_name-$pkgver/tests"; } 30prepare() { rm -rf "$_name-$pkgver/tests"; }