summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ouch/.SRCINFO2
-rw-r--r--ouch/PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/ouch/.SRCINFO b/ouch/.SRCINFO
index 8a9519e..27bd7fc 100644
--- a/ouch/.SRCINFO
+++ b/ouch/.SRCINFO
@@ -1,7 +1,7 @@
1pkgbase = ouch 1pkgbase = ouch
2 pkgdesc = Painless compression and decompression in the terminal 2 pkgdesc = Painless compression and decompression in the terminal
3 pkgver = 0.4.0 3 pkgver = 0.4.0
4 pkgrel = 1 4 pkgrel = 2
5 url = https://github.com/ouch-org/ouch 5 url = https://github.com/ouch-org/ouch
6 arch = x86_64 6 arch = x86_64
7 license = MIT 7 license = MIT
diff --git a/ouch/PKGBUILD b/ouch/PKGBUILD
index 66ff64c..0d3cfee 100644
--- a/ouch/PKGBUILD
+++ b/ouch/PKGBUILD
@@ -2,7 +2,7 @@
2 2
3pkgname=ouch 3pkgname=ouch
4pkgver=0.4.0 4pkgver=0.4.0
5pkgrel=1 5pkgrel=2
6pkgdesc="Painless compression and decompression in the terminal" 6pkgdesc="Painless compression and decompression in the terminal"
7arch=('x86_64') 7arch=('x86_64')
8url="https://github.com/ouch-org/ouch" 8url="https://github.com/ouch-org/ouch"
@@ -14,6 +14,8 @@ sha256sums=('3e126f00e1ad82ef4abfd28f86dac53b366a29de6a70359e734ecc8748f580fc')
14 14
15prepare() { 15prepare() {
16 cd "$srcdir/$pkgname-$pkgver" 16 cd "$srcdir/$pkgname-$pkgver"
17 # TODO: Remove on next release <27-11-22, yigit> #
18 rm -f rust-toolchain
17 cargo fetch --locked --target "$CARCH-unknown-linux-gnu" 19 cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
18} 20}
19 21
@@ -21,7 +23,7 @@ build() {
21 cd "$srcdir/$pkgname-$pkgver" 23 cd "$srcdir/$pkgname-$pkgver"
22 export RUSTUP_TOOLCHAIN=stable 24 export RUSTUP_TOOLCHAIN=stable
23 export CARGO_TARGET_DIR=target 25 export CARGO_TARGET_DIR=target
24 GEN_COMPLETIONS=1 OUCH_ARTIFACTS_FOLDER=artifacts cargo build --frozen --release --all-features 26 OUCH_ARTIFACTS_FOLDER=artifacts cargo build --frozen --release --all-features
25} 27}
26 28
27check() { 29check() {