summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--ChangeLog8
-rw-r--r--PKGBUILD4
3 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f8ad8d..1828243 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
1pkgbase = wapiti 1pkgbase = wapiti
2 pkgdesc = Comprehensive web app vulnerability scanner written in Python 2 pkgdesc = Comprehensive web app vulnerability scanner written in Python
3 pkgver = 3.1.0 3 pkgver = 3.1.1
4 pkgrel = 1 4 pkgrel = 1
5 url = https://wapiti-scanner.github.io 5 url = https://wapiti-scanner.github.io
6 changelog = ChangeLog 6 changelog = ChangeLog
@@ -22,7 +22,7 @@ pkgbase = wapiti
22 optdepends = python-requests-kerberos: Kerberos authentication 22 optdepends = python-requests-kerberos: Kerberos authentication
23 optdepends = python-requests-ntlm: NTLM authentication 23 optdepends = python-requests-ntlm: NTLM authentication
24 options = zipman 24 options = zipman
25 source = https://github.com/wapiti-scanner/wapiti/releases/download/3.1.0/wapiti3-3.1.0.tar.gz 25 source = https://github.com/wapiti-scanner/wapiti/releases/download/3.1.1/wapiti3-3.1.1.tar.gz
26 sha256sums = 4974204e5da966c3e91946465840420c708c034a7c030c5597d3c36badf05a0f 26 sha256sums = d51645fc9cb65a264d87ee38aa8b6733039940afcfa74446f34cd3eef182da36
27 27
28pkgname = wapiti 28pkgname = wapiti
diff --git a/ChangeLog b/ChangeLog
index d5aec20..9934ce9 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,11 @@
123/02/2022
2 Wapiti 3.1.1
3 Crawler: Fix a bug preventing Wapiti to scan websites with bad ciphers (SSL 3, TLS 1.0 for example)
4 Report: Add some unicode emojis in the HTML report to indicate the criticality of each vulnerability
5 XXE: more payloads to target non-PHP applications + raise a warning when the DTD file was reached by the target but exfiltration didn't succeed
6 CLI: --update option will only update chosen modules
7 CLI: New --data option allows to launch attacks on a single POST request. This option expect a url-encoded string.
8
106/02/2022 906/02/2022
2 Wapiti 3.1.0 10 Wapiti 3.1.0
3 Crawler: Fix passing named "button" tags in HTML forms 11 Crawler: Fix passing named "button" tags in HTML forms
diff --git a/PKGBUILD b/PKGBUILD
index dee5188..89cce86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
4 4
5pkgname=wapiti 5pkgname=wapiti
6 6
7pkgver=3.1.0 7pkgver=3.1.1
8_name="$pkgname${pkgver:0:1}" 8_name="$pkgname${pkgver:0:1}"
9pkgrel=1 9pkgrel=1
10 10
@@ -25,7 +25,7 @@ options=('zipman')
25changelog=ChangeLog 25changelog=ChangeLog
26source=("https://github.com/$pkgname-scanner/$pkgname/releases/download/$pkgver/$_name-$pkgver.tar.gz") 26source=("https://github.com/$pkgname-scanner/$pkgname/releases/download/$pkgver/$_name-$pkgver.tar.gz")
27#source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$_name-$pkgver.tar.gz") 27#source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$_name-$pkgver.tar.gz")
28sha256sums=('4974204e5da966c3e91946465840420c708c034a7c030c5597d3c36badf05a0f') 28sha256sums=('d51645fc9cb65a264d87ee38aa8b6733039940afcfa74446f34cd3eef182da36')
29 29
30 30
31prepare() { rm -rf "$_name-$pkgver/tests"; } 31prepare() { rm -rf "$_name-$pkgver/tests"; }