summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 0000000..6a85209
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
1pkgbase = quich
2 pkgdesc = Small, fast and useful calculator for your terminal with multiple functions and options.
3 pkgver = 2.1
4 pkgrel = 1
5 url = https://github.com/Usbac/quich
6 arch = x86_64
7 license = MIT
8 provides = quich
9 source = https://github.com/Usbac/quich/archive/v2.1.tar.gz
10 md5sums = 7105380d4350fc90027949629aeaa235
11
12pkgname = quich
13
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..75cb413
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
1src/
2pkg/
3*.tar.xz
4*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..c2eb12d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
1# Maintainer: vscncls <lucaslou4@protonmail.com>
2
3pkgname=quich
4pkgver=2.1
5pkgrel=1
6pkgdesc="Small, fast and useful calculator for your terminal with multiple functions and options."
7url="https://github.com/Usbac/quich"
8arch=('x86_64')
9license=('MIT')
10depends=()
11makedepends=()
12provides=("$pkgname")
13conflicts=()
14source=("${url}/archive/v${pkgver}.tar.gz")
15md5sums=('7105380d4350fc90027949629aeaa235')
16
17build() {
18 cd $pkgname-$pkgver
19 NAME=$pkgname make quich
20}
21
22package() {
23 install -Dm755 $pkgname-$pkgver/$pkgname $pkgdir/usr/bin/$pkgname
24
25 install -Dm644 $pkgname-$pkgver/LICENSE $pkgdir/usr/share/licenses/$pkgname
26}