summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD17
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 0000000..53f49b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
1pkgbase = wapiti
2 pkgdesc = A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections...
3 pkgver = 2.3.0
4 pkgrel = 2
5 url = http://wapiti.sourceforge.net/
6 arch = any
7 license = GPL
8 depends = python2
9 depends = python2-setuptools
10 depends = python2-requests
11 depends = python2-beautifulsoup3
12 source = http://downloads.sourceforge.net/sourceforge/wapiti/wapiti/wapiti-2.3.0/wapiti-2.3.0.tar.gz
13 md5sums = dd8b0ab120518215abf9c7b22251fd8b
14
15pkgname = wapiti
16
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..1d2d036
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
1# Maintainer: mickael9 <mickael9 at gmail dot com>
2pkgname=wapiti
3pkgver=2.3.0
4pkgrel=2
5pkgdesc="A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections..."
6url='http://wapiti.sourceforge.net/'
7license=(GPL)
8depends=(python2 python2-setuptools python2-requests python2-beautifulsoup3)
9arch=(any)
10
11source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}/${pkgname}-${pkgver}/$pkgname-$pkgver.tar.gz)
12md5sums=('dd8b0ab120518215abf9c7b22251fd8b')
13
14package() {
15 cd "$srcdir/${pkgname}-${pkgver}"
16 python2 setup.py install --root="$pkgdir/" --optimize=1
17}