diff options
-rw-r--r-- | .SRCINFO | 8 | ||||
-rw-r--r-- | PKGBUILD | 10 |
2 files changed, 9 insertions, 9 deletions
@@ -1,7 +1,7 @@ | |||
1 | pkgbase = wapiti | 1 | pkgbase = wapiti |
2 | pkgdesc = A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections... | 2 | pkgdesc = A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections... |
3 | pkgver = 3.0.0 | 3 | pkgver = 3.0.1 |
4 | pkgrel = 2 | 4 | pkgrel = 1 |
5 | url = http://wapiti.sourceforge.net/ | 5 | url = http://wapiti.sourceforge.net/ |
6 | arch = any | 6 | arch = any |
7 | license = GPL | 7 | license = GPL |
@@ -14,8 +14,8 @@ pkgbase = wapiti | |||
14 | depends = python-yaswfp | 14 | depends = python-yaswfp |
15 | depends = python-mako | 15 | depends = python-mako |
16 | depends = python-pysocks | 16 | depends = python-pysocks |
17 | source = http://downloads.sourceforge.net/sourceforge/wapiti/wapiti/wapiti-3.0.0/wapiti-3.0.0.tar.gz | 17 | source = http://downloads.sourceforge.net/sourceforge/wapiti/wapiti/wapiti-3.0.1/wapiti3-3.0.1.tar.gz |
18 | sha256sums = 4238b336773b6cb1a36a5a2f2fa0bbe413a41e13fa6f5b109dbf6bbc897e4b46 | 18 | sha256sums = bbb8c8f572afe77319734489a6ca0b211df4b87ad294db79b8bf0bda1c5aff29 |
19 | 19 | ||
20 | pkgname = wapiti | 20 | pkgname = wapiti |
21 | 21 | ||
@@ -1,18 +1,18 @@ | |||
1 | # Maintainer: mickael9 <mickael9 at gmail dot com> | 1 | # Maintainer: mickael9 <mickael9 at gmail dot com> |
2 | 2 | ||
3 | pkgname=wapiti | 3 | pkgname=wapiti |
4 | pkgver=3.0.0 | 4 | pkgver=3.0.1 |
5 | pkgrel=2 | 5 | pkgrel=1 |
6 | pkgdesc="A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections..." | 6 | pkgdesc="A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections..." |
7 | url='http://wapiti.sourceforge.net/' | 7 | url='http://wapiti.sourceforge.net/' |
8 | license=(GPL) | 8 | license=(GPL) |
9 | depends=(python python-setuptools python-requests python-beautifulsoup4 python-lxml python-tld python-yaswfp python-mako python-pysocks) | 9 | depends=(python python-setuptools python-requests python-beautifulsoup4 python-lxml python-tld python-yaswfp python-mako python-pysocks) |
10 | arch=(any) | 10 | arch=(any) |
11 | 11 | ||
12 | source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz") | 12 | source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}/${pkgname}-${pkgver}/${pkgname}${pkgver:0:1}-${pkgver}.tar.gz") |
13 | sha256sums=('4238b336773b6cb1a36a5a2f2fa0bbe413a41e13fa6f5b109dbf6bbc897e4b46') | 13 | sha256sums=('bbb8c8f572afe77319734489a6ca0b211df4b87ad294db79b8bf0bda1c5aff29') |
14 | 14 | ||
15 | package() { | 15 | package() { |
16 | cd "${srcdir}/${pkgname}-${pkgver}" | 16 | cd "${srcdir}/${pkgname}${pkgver:0:1}-${pkgver}" |
17 | python setup.py install --root="${pkgdir}/" --optimize=1 | 17 | python setup.py install --root="${pkgdir}/" --optimize=1 |
18 | } | 18 | } |