summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--py-spy/.SRCINFO14
-rw-r--r--py-spy/.gitignore3
-rw-r--r--py-spy/PKGBUILD24
3 files changed, 41 insertions, 0 deletions
diff --git a/py-spy/.SRCINFO b/py-spy/.SRCINFO
new file mode 100644
index 0000000..5de7bfb
--- /dev/null
+++ b/py-spy/.SRCINFO
@@ -0,0 +1,14 @@
1pkgbase = py-spy
2 pkgdesc = Sampling profiler for Python programs
3 pkgver = 0.3.14
4 pkgrel = 1
5 url = https://github.com/benfred/py-spy
6 arch = x86_64
7 license = GPL3
8 makedepends = rust
9 makedepends = cargo
10 makedepends = libunwind
11 source = https://github.com/benfred/py-spy/archive/refs/tags/v0.3.14.tar.gz
12 sha512sums = f079b002248a033eac3b93723fd267e6cbdb415ac3172ace0d14eb9cd87a1e4adf471eeec641f9644abe8a4fab43b48db7440b4b1242ea18e02bcc574104d303
13
14pkgname = py-spy
diff --git a/py-spy/.gitignore b/py-spy/.gitignore
new file mode 100644
index 0000000..f9e46d0
--- /dev/null
+++ b/py-spy/.gitignore
@@ -0,0 +1,3 @@
1*.tar.*
2/src
3/pkg
diff --git a/py-spy/PKGBUILD b/py-spy/PKGBUILD
new file mode 100644
index 0000000..3534b8e
--- /dev/null
+++ b/py-spy/PKGBUILD
@@ -0,0 +1,24 @@
1# Maintainer: lilydjwg <lilydjwg@gmail.com>
2# Contributor: Clayton Craft <clayton@craftyguy.net>
3pkgname=py-spy
4pkgver=0.3.14
5pkgrel=1
6pkgdesc="Sampling profiler for Python programs"
7arch=('x86_64')
8license=('GPL3')
9url="https://github.com/benfred/py-spy"
10makedepends=('rust' 'cargo' 'libunwind')
11source=("https://github.com/benfred/py-spy/archive/refs/tags/v${pkgver}.tar.gz")
12sha512sums=('f079b002248a033eac3b93723fd267e6cbdb415ac3172ace0d14eb9cd87a1e4adf471eeec641f9644abe8a4fab43b48db7440b4b1242ea18e02bcc574104d303')
13
14build() {
15 cd "${srcdir}/${pkgname}-${pkgver}"
16 cargo build --release
17}
18
19package() {
20 cd "${srcdir}/${pkgname}-${pkgver}"
21 install -Dm755 "target/release/py-spy" "${pkgdir}/usr/bin/py-spy"
22 install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
23 install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
24}