diff options
author | Yigit Sever | 2022-07-14 02:06:42 +0300 |
---|---|---|
committer | Yigit Sever | 2022-07-14 02:06:42 +0300 |
commit | 5457499747ad363cac54180873270dd69109b268 (patch) | |
tree | c5ca116e828e3fa4d6fd86e02b92ff5f87e37e62 /wapiti/PKGBUILD | |
parent | 1442888b7776777cf39eec0158fbbf164c1f142d (diff) | |
download | packages-5457499747ad363cac54180873270dd69109b268.tar.gz packages-5457499747ad363cac54180873270dd69109b268.tar.bz2 packages-5457499747ad363cac54180873270dd69109b268.zip |
wapiti: update to 3.1.3
Diffstat (limited to 'wapiti/PKGBUILD')
-rw-r--r-- | wapiti/PKGBUILD | 29 |
1 files changed, 13 insertions, 16 deletions
diff --git a/wapiti/PKGBUILD b/wapiti/PKGBUILD index 5020cab..d645313 100644 --- a/wapiti/PKGBUILD +++ b/wapiti/PKGBUILD | |||
@@ -1,37 +1,37 @@ | |||
1 | # Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/) | 1 | # Maintainer : Yigit Sever <yigit at yigitsever dot com> |
2 | # Contributor : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/) | ||
2 | # Contributor : mickael9 <mickael9 at gmail dot com> | 3 | # Contributor : mickael9 <mickael9 at gmail dot com> |
3 | 4 | ||
4 | |||
5 | pkgname=wapiti | 5 | pkgname=wapiti |
6 | 6 | pkgver=3.1.3 | |
7 | pkgver=3.1.2 | ||
8 | _name="$pkgname${pkgver:0:1}" | 7 | _name="$pkgname${pkgver:0:1}" |
9 | pkgrel=1 | 8 | pkgrel=1 |
10 | |||
11 | pkgdesc='Comprehensive web app vulnerability scanner written in Python' | 9 | pkgdesc='Comprehensive web app vulnerability scanner written in Python' |
12 | arch=('any') | 10 | arch=('any') |
13 | url="https://$pkgname-scanner.github.io" | 11 | url="https://$pkgname-scanner.github.io" |
14 | license=('GPL') | 12 | license=('GPL') |
15 | |||
16 | makedepends=('python-setuptools') | 13 | makedepends=('python-setuptools') |
17 | depends=('python' 'python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-yaswfp' | 14 | depends=('python' 'python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-yaswfp' |
18 | 'python-browser-cookie3' 'python-mako' 'python-python-socks' 'python-tld' 'python-httpx' | 15 | 'python-browser-cookie3' 'python-mako' 'python-python-socks' 'python-tld' 'python-httpx' |
19 | 'python-aiocache' 'python-sqlalchemy') | 16 | 'python-aiocache' 'python-aiosqlite' 'python-sqlalchemy' 'python-loguru' 'python-cryptography') |
20 | optdepends=('python-requests-kerberos: Kerberos authentication' | 17 | optdepends=('python-requests-kerberos: Kerberos authentication' |
21 | 'python-requests-ntlm: NTLM authentication') | 18 | 'python-requests-ntlm: NTLM authentication') |
22 | |||
23 | options=('zipman') | 19 | options=('zipman') |
24 | |||
25 | changelog=ChangeLog | 20 | changelog=ChangeLog |
26 | source=("https://github.com/$pkgname-scanner/$pkgname/releases/download/$pkgver/$_name-$pkgver.tar.gz") | 21 | source=("https://github.com/$pkgname-scanner/$pkgname/releases/download/$pkgver/$_name-$pkgver.tar.gz") |
27 | #source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$_name-$pkgver.tar.gz") | 22 | sha256sums=('83ffef39199f92f530f7de7b47dbfb93ab2c9c97d3bbee93473084cba5796c61') |
28 | sha256sums=('d10c51577792f949c9afa143043c9a25e6e86542cb48489d944ace45612aaea9') | ||
29 | |||
30 | 23 | ||
31 | prepare() { rm -rf "$_name-$pkgver/tests"; } | 24 | prepare() { |
25 | rm -rf "$_name-$pkgver/tests" | ||
26 | } | ||
32 | 27 | ||
33 | build() { | 28 | build() { |
34 | cd "$_name-$pkgver" | 29 | cd "$_name-$pkgver" |
30 | sed -i '/mitmproxy==8.0.0/s/==8.0.0/>=8.0.0/' setup.py | ||
31 | sed -i '/dnspython==2.1.0/s/==2.1.0/>=2.1.0/' setup.py | ||
32 | sed -i '/cryptography==36.0.2/s/==36.0.2/>=36.0.2/' setup.py | ||
33 | sed -i '/browser-cookie3==0.11.4/s/==0.11.4/>=0.11.4/' setup.py | ||
34 | sed -i '/importlib_metadata==3.7.2/s/==3.7.2/>=3.7.2/' setup.py | ||
35 | python setup.py build | 35 | python setup.py build |
36 | } | 36 | } |
37 | 37 | ||
@@ -39,6 +39,3 @@ package() { | |||
39 | cd "$_name-$pkgver" | 39 | cd "$_name-$pkgver" |
40 | PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build | 40 | PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build |
41 | } | 41 | } |
42 | |||
43 | |||
44 | # vim: ts=2 sw=2 et ft=PKGBUILD: | ||