diff options
author | Yigit Sever | 2021-10-29 01:30:24 +0300 |
---|---|---|
committer | Yigit Sever | 2021-10-29 01:30:24 +0300 |
commit | 31d147b20c67d95a9e306d0749200bf964ac42af (patch) | |
tree | b0fbe2bb5aa0fec9983746a91d188643ca93466d /unsilence | |
parent | 4a31e5e0f3442a4a5ec9fba94f7bbc2c88312c69 (diff) | |
download | packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.gz packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.bz2 packages-31d147b20c67d95a9e306d0749200bf964ac42af.zip |
Use actual files instead of submodules
Diffstat (limited to 'unsilence')
m--------- | unsilence | 22 | ||||
-rw-r--r-- | unsilence/.SRCINFO | 16 | ||||
-rw-r--r-- | unsilence/.gitignore | 4 | ||||
-rw-r--r-- | unsilence/PKGBUILD | 28 |
4 files changed, 48 insertions, 22 deletions
diff --git a/unsilence b/unsilence deleted file mode 160000 | |||
Subproject 668443ef7ab8bc1109df5d219f8bf32f6806e0a | |||
diff --git a/unsilence/.SRCINFO b/unsilence/.SRCINFO new file mode 100644 index 0000000..958ad04 --- /dev/null +++ b/unsilence/.SRCINFO | |||
@@ -0,0 +1,16 @@ | |||
1 | pkgbase = unsilence | ||
2 | pkgdesc = Console Interface and Library to remove silent parts of a media file | ||
3 | pkgver = 1.0.8 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/lagmoellertim/unsilence | ||
6 | arch = any | ||
7 | license = MIT | ||
8 | makedepends = python-setuptools | ||
9 | depends = ffmpeg | ||
10 | depends = python | ||
11 | depends = python-argparse | ||
12 | depends = python-rich | ||
13 | source = unsilence-1.0.8.tar.gz::https://github.com/lagmoellertim/unsilence/archive/1.0.8.tar.gz | ||
14 | sha256sums = bd377d279ae155d02cc29cb6fbe836021c2ca2d1bc2766675c0beeb2f50c9e43 | ||
15 | |||
16 | pkgname = unsilence | ||
diff --git a/unsilence/.gitignore b/unsilence/.gitignore new file mode 100644 index 0000000..05c6d4d --- /dev/null +++ b/unsilence/.gitignore | |||
@@ -0,0 +1,4 @@ | |||
1 | * | ||
2 | !.gitignore | ||
3 | !.SRCINFO | ||
4 | !PKGBUILD | ||
diff --git a/unsilence/PKGBUILD b/unsilence/PKGBUILD new file mode 100644 index 0000000..ca792d2 --- /dev/null +++ b/unsilence/PKGBUILD | |||
@@ -0,0 +1,28 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz> | ||
3 | |||
4 | pkgname=unsilence | ||
5 | pkgver=1.0.8 | ||
6 | pkgrel=1 | ||
7 | pkgdesc='Console Interface and Library to remove silent parts of a media file' | ||
8 | arch=('any') | ||
9 | url='https://github.com/lagmoellertim/unsilence' | ||
10 | license=('MIT') | ||
11 | depends=('ffmpeg' 'python' 'python-argparse' 'python-rich') | ||
12 | makedepends=('python-setuptools') | ||
13 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") | ||
14 | sha256sums=('bd377d279ae155d02cc29cb6fbe836021c2ca2d1bc2766675c0beeb2f50c9e43') | ||
15 | |||
16 | build() { | ||
17 | cd "${pkgname}-${pkgver}" | ||
18 | sed -i 's/9.10.0/10.11.0/' requirements.txt | ||
19 | python setup.py build | ||
20 | } | ||
21 | |||
22 | package() { | ||
23 | cd "${pkgname}-${pkgver}" | ||
24 | python setup.py install --root="${pkgdir}" --optimize=1 --skip-build | ||
25 | install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md' | ||
26 | install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE' | ||
27 | rm -r "${pkgdir}/usr/lib/python"*'/site-packages/examples' | ||
28 | } | ||