summaryrefslogtreecommitdiffstats
path: root/python-jstyleson/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2023-06-08 01:29:53 +0300
committerYigit Sever2023-06-08 01:29:53 +0300
commit862a5f005da9c24f0ddc8742e2302de0d595f779 (patch)
treea6bedb5771c1983e8232da6e57ecf38583f1a212 /python-jstyleson/PKGBUILD
parentc36ef0bec1c968d240120c9e4442ddd0b233253e (diff)
parenta7b184f2e7d392c19cd70287496053eaa419c954 (diff)
downloadpackages-862a5f005da9c24f0ddc8742e2302de0d595f779.tar.gz
packages-862a5f005da9c24f0ddc8742e2302de0d595f779.tar.bz2
packages-862a5f005da9c24f0ddc8742e2302de0d595f779.zip
Add 'python-jstyleson/' from commit 'a7b184f2e7d392c19cd70287496053eaa419c954'
git-subtree-dir: python-jstyleson git-subtree-mainline: c36ef0bec1c968d240120c9e4442ddd0b233253e git-subtree-split: a7b184f2e7d392c19cd70287496053eaa419c954
Diffstat (limited to 'python-jstyleson/PKGBUILD')
-rw-r--r--python-jstyleson/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/python-jstyleson/PKGBUILD b/python-jstyleson/PKGBUILD
new file mode 100644
index 0000000..1281310
--- /dev/null
+++ b/python-jstyleson/PKGBUILD
@@ -0,0 +1,23 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2pkgname=python-jstyleson
3_name=${pkgname#python-}
4pkgver=0.0.2
5pkgrel=1
6pkgdesc="Library to parse JSON with js-style comments."
7arch=('any')
8url="https://pypi.org/project/jstyleson/"
9license=('MIT')
10depends=('python')
11makedepends=('python-setuptools')
12source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
13sha256sums=('680003f3b15a2959e4e6a351f3b858e3c07dd3e073a0d54954e34d8ea5e1308e')
14
15build() {
16 cd "${_name}-${pkgver}"
17 python setup.py build
18}
19
20package() {
21 cd "${_name}-${pkgver}"
22 python setup.py install --root="$pkgdir" --optimize=1
23}