summaryrefslogtreecommitdiffstats
path: root/python-html-text
diff options
context:
space:
mode:
authorYigit Sever2024-11-18 15:56:57 +0100
committerYigit Sever2024-11-18 15:56:57 +0100
commitbc557aabd5252542ee14567c48948de3edb95498 (patch)
tree06e4d4702d4700a8c935213dbf454c7a764b29ed /python-html-text
parent30dd6f30b31eb1fa855423294d5ae0548183bbec (diff)
downloadpackages-bc557aabd5252542ee14567c48948de3edb95498.tar.gz
packages-bc557aabd5252542ee14567c48948de3edb95498.tar.bz2
packages-bc557aabd5252542ee14567c48948de3edb95498.zip
upgpkg: python-html-text 0.6.2-1
Change upstream source to up-to-date fork https://github.com/zytedata/html-text
Diffstat (limited to 'python-html-text')
-rw-r--r--python-html-text/.SRCINFO12
-rw-r--r--python-html-text/PKGBUILD14
2 files changed, 14 insertions, 12 deletions
diff --git a/python-html-text/.SRCINFO b/python-html-text/.SRCINFO
index 5922460..f2ecb42 100644
--- a/python-html-text/.SRCINFO
+++ b/python-html-text/.SRCINFO
@@ -1,13 +1,15 @@
1pkgbase = python-html-text 1pkgbase = python-html-text
2 pkgdesc = Python library to extract text from HTML 2 pkgdesc = Python library to extract text from HTML
3 pkgver = 0.5.2 3 pkgver = 0.6.2
4 pkgrel = 1 4 pkgrel = 1
5 url = https://github.com/TeamHG-Memex/html-text 5 url = https://github.com/zytedata/html-text
6 arch = any 6 arch = any
7 license = MIT 7 license = MIT
8 makedepends = python-setuptools 8 makedepends = python-build
9 makedepends = python-installer
10 makedepends = python-wheel
9 depends = python-lxml 11 depends = python-lxml
10 source = python-html-text-0.5.2.tar.gz::https://github.com/TeamHG-Memex/html-text/archive/0.5.2.tar.gz 12 source = python-html-text-0.6.2.tar.gz::https://github.com/zytedata/html-text/archive/0.6.2.tar.gz
11 sha256sums = c75a1da10d649f55162446de57f98374059a998071110a343815841286a442f9 13 sha256sums = 2bda73192e3009bacb626c8feacc9ab5f0685947eb5847e181fb1d330410bcc3
12 14
13pkgname = python-html-text 15pkgname = python-html-text
diff --git a/python-html-text/PKGBUILD b/python-html-text/PKGBUILD
index 140450d..1cb0452 100644
--- a/python-html-text/PKGBUILD
+++ b/python-html-text/PKGBUILD
@@ -1,23 +1,23 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com> 1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2pkgname=python-html-text 2pkgname=python-html-text
3_pkgname=html-text 3_pkgname=html-text
4pkgver=0.5.2 4pkgver=0.6.2
5pkgrel=1 5pkgrel=1
6pkgdesc="Python library to extract text from HTML" 6pkgdesc="Python library to extract text from HTML"
7arch=('any') 7arch=('any')
8url="https://github.com/TeamHG-Memex/html-text" 8url="https://github.com/zytedata/html-text"
9license=('MIT') 9license=('MIT')
10depends=('python-lxml') 10depends=(python-lxml)
11makedepends=('python-setuptools') 11makedepends=(python-build python-installer python-wheel)
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") 12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
13sha256sums=('c75a1da10d649f55162446de57f98374059a998071110a343815841286a442f9') 13sha256sums=('2bda73192e3009bacb626c8feacc9ab5f0685947eb5847e181fb1d330410bcc3')
14 14
15build() { 15build() {
16 cd "${_pkgname}-${pkgver}" 16 cd "${_pkgname}-${pkgver}"
17 python setup.py build 17 python -m build --wheel --no-isolation
18} 18}
19 19
20package() { 20package() {
21 cd "${_pkgname}-${pkgver}" 21 cd "${_pkgname}-${pkgver}"
22 python setup.py install --root="$pkgdir" --optimize=1 22 python -m installer --destdir="$pkgdir" dist/*.whl
23} 23}