summaryrefslogtreecommitdiffstats
path: root/python-html-text
diff options
context:
space:
mode:
authorYigit Sever2024-11-18 16:04:44 +0100
committerYigit Sever2024-11-18 16:04:44 +0100
commit213abdb88a26d37174ac9f61a04d7bfd389f20b0 (patch)
tree06e4d4702d4700a8c935213dbf454c7a764b29ed /python-html-text
parentab2396d8287482c81dcf313cb2ab52aeb02de2fe (diff)
parent658adf4fe70d0a4de0ecf3a7773028d7d098bfff (diff)
downloadpackages-main.tar.gz
packages-main.tar.bz2
packages-main.zip
Add 'python-html-text/' from commit '658adf4fe70d0a4de0ecf3a7773028d7d098bfff'HEADmain
git-subtree-dir: python-html-text git-subtree-mainline: ab2396d8287482c81dcf313cb2ab52aeb02de2fe git-subtree-split: 658adf4fe70d0a4de0ecf3a7773028d7d098bfff
Diffstat (limited to 'python-html-text')
-rw-r--r--python-html-text/.SRCINFO15
-rw-r--r--python-html-text/PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/python-html-text/.SRCINFO b/python-html-text/.SRCINFO
new file mode 100644
index 0000000..f2ecb42
--- /dev/null
+++ b/python-html-text/.SRCINFO
@@ -0,0 +1,15 @@
1pkgbase = python-html-text
2 pkgdesc = Python library to extract text from HTML
3 pkgver = 0.6.2
4 pkgrel = 1
5 url = https://github.com/zytedata/html-text
6 arch = any
7 license = MIT
8 makedepends = python-build
9 makedepends = python-installer
10 makedepends = python-wheel
11 depends = python-lxml
12 source = python-html-text-0.6.2.tar.gz::https://github.com/zytedata/html-text/archive/0.6.2.tar.gz
13 sha256sums = 2bda73192e3009bacb626c8feacc9ab5f0685947eb5847e181fb1d330410bcc3
14
15pkgname = python-html-text
diff --git a/python-html-text/PKGBUILD b/python-html-text/PKGBUILD
new file mode 100644
index 0000000..1cb0452
--- /dev/null
+++ b/python-html-text/PKGBUILD
@@ -0,0 +1,23 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2pkgname=python-html-text
3_pkgname=html-text
4pkgver=0.6.2
5pkgrel=1
6pkgdesc="Python library to extract text from HTML"
7arch=('any')
8url="https://github.com/zytedata/html-text"
9license=('MIT')
10depends=(python-lxml)
11makedepends=(python-build python-installer python-wheel)
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
13sha256sums=('2bda73192e3009bacb626c8feacc9ab5f0685947eb5847e181fb1d330410bcc3')
14
15build() {
16 cd "${_pkgname}-${pkgver}"
17 python -m build --wheel --no-isolation
18}
19
20package() {
21 cd "${_pkgname}-${pkgver}"
22 python -m installer --destdir="$pkgdir" dist/*.whl
23}