summaryrefslogtreecommitdiffstats
path: root/python-extruct/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2023-06-08 01:21:35 +0300
committerYigit Sever2023-06-08 01:21:35 +0300
commit309498e610a10b8df8eccc41dab6560a3d95c9c7 (patch)
tree90fe2e3d561cdd7bb9917fcb4c114caeed5bdb7f /python-extruct/PKGBUILD
parent4ad3153961d105e05714df6216ef5cae6233a589 (diff)
downloadpackages-309498e610a10b8df8eccc41dab6560a3d95c9c7.tar.gz
packages-309498e610a10b8df8eccc41dab6560a3d95c9c7.tar.bz2
packages-309498e610a10b8df8eccc41dab6560a3d95c9c7.zip
Deleted package: python-extruct
Diffstat (limited to 'python-extruct/PKGBUILD')
-rw-r--r--python-extruct/PKGBUILD25
1 files changed, 0 insertions, 25 deletions
diff --git a/python-extruct/PKGBUILD b/python-extruct/PKGBUILD
deleted file mode 100644
index 2c7b5a9..0000000
--- a/python-extruct/PKGBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=python-extruct
4_pkgname=extruct
5pkgver=0.14.0
6pkgrel=1
7pkgdesc="Extract embedded metadata from HTML markup"
8arch=('any')
9url="https://github.com/scrapinghub/extruct"
10license=('custom')
11depends=('python-lxml' 'python-requests' 'python-rdflib' 'python-rdflib-jsonld' 'python-pyrdfa3' 'python-mf2py' 'python-six' 'python-w3lib' 'python-html-text' 'python-jstyleson')
12makedepends=('python-setuptools')
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
14sha256sums=('7bb956c55eea39fddfb0b827a676abb19abac2af009c1b420b3a004f3e2b1262')
15
16build() {
17 cd "${_pkgname}-${pkgver}"
18 python setup.py build
19}
20
21package() {
22 cd "${_pkgname}-${pkgver}"
23 python setup.py install --root="$pkgdir" --optimize=1
24 install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
25}