diff options
author | Yigit Sever | 2022-06-18 15:42:07 +0300 |
---|---|---|
committer | Yigit Sever | 2022-06-18 15:42:07 +0300 |
commit | 46775cb26629515ce2c11b4d866efafb15fda222 (patch) | |
tree | 0dfb427e4259961d6c0850172473f0eb5300d4c0 /proxify-bin/PKGBUILD | |
parent | d7ead29e1263ec8dd374b3bafbe78c7e4f996644 (diff) | |
download | packages-46775cb26629515ce2c11b4d866efafb15fda222.tar.gz packages-46775cb26629515ce2c11b4d866efafb15fda222.tar.bz2 packages-46775cb26629515ce2c11b4d866efafb15fda222.zip |
proxify-bin: Adopted
Diffstat (limited to 'proxify-bin/PKGBUILD')
-rw-r--r-- | proxify-bin/PKGBUILD | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/proxify-bin/PKGBUILD b/proxify-bin/PKGBUILD new file mode 100644 index 0000000..6314a04 --- /dev/null +++ b/proxify-bin/PKGBUILD | |||
@@ -0,0 +1,28 @@ | |||
1 | # Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz> | ||
2 | |||
3 | _pkgname='proxify' | ||
4 | pkgname="${_pkgname}-bin" | ||
5 | pkgver=0.0.3 | ||
6 | pkgrel=1 | ||
7 | pkgdesc='Swiss Army knife Proxy tool for HTTP/HTTPS traffic capture, manipulation and replay' | ||
8 | arch=('x86_64' 'armv6h' 'aarch64') | ||
9 | url='https://github.com/projectdiscovery/proxify' | ||
10 | license=('MIT') | ||
11 | provides=("${_pkgname}") | ||
12 | conflicts=("${_pkgname}") | ||
13 | |||
14 | source_x86_64=("${_pkgname}-${pkgver}-x86_64.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.tar.gz") | ||
15 | source_armv6h=("${_pkgname}-${pkgver}-armv6.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_armv6.tar.gz") | ||
16 | source_aarch64=("${_pkgname}-${pkgver}-aarch64.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.tar.gz") | ||
17 | |||
18 | sha256sums_x86_64=('fcc25d829cae1c74c36556dfc12d1e2f18b639a0a05d03a755a5c62489c3ac3a') | ||
19 | sha256sums_armv6h=('6049c825de4ce20a92e0f70757e06b408d91834a236fd0901f6dd2271b723005') | ||
20 | sha256sums_aarch64=('4440dfe5ed567d6a4f1e8b97e62ef7cadcf0bc2540e92c5ff3180de12a7b7948') | ||
21 | |||
22 | package() { | ||
23 | install -Dvm755 "${_pkgname}" -t "${pkgdir}/usr/bin" | ||
24 | install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}" | ||
25 | install -Dvm644 'LICENSE.MD' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE" | ||
26 | } | ||
27 | |||
28 | # vim: ts=2 sw=2 et: | ||