diff options
author | Yigit Sever | 2021-11-16 15:56:06 +0300 |
---|---|---|
committer | Yigit Sever | 2021-11-16 15:56:06 +0300 |
commit | 5f672acc55ffe9d72c39d76f4bc1ae8ec6539067 (patch) | |
tree | e397ba75937e9fe569b57cc736cdd5fdda14a112 /ouch-git | |
parent | b12b893ba2ae85b42c9a370dcf8885fe2755734c (diff) | |
download | packages-5f672acc55ffe9d72c39d76f4bc1ae8ec6539067.tar.gz packages-5f672acc55ffe9d72c39d76f4bc1ae8ec6539067.tar.bz2 packages-5f672acc55ffe9d72c39d76f4bc1ae8ec6539067.zip |
Tracking adopted packages
- dvc
- flowy
- ouch{-bin, -git,}
Diffstat (limited to 'ouch-git')
-rw-r--r-- | ouch-git/.SRCINFO | 16 | ||||
-rw-r--r-- | ouch-git/PKGBUILD | 51 |
2 files changed, 67 insertions, 0 deletions
diff --git a/ouch-git/.SRCINFO b/ouch-git/.SRCINFO new file mode 100644 index 0000000..8f5b5e1 --- /dev/null +++ b/ouch-git/.SRCINFO | |||
@@ -0,0 +1,16 @@ | |||
1 | pkgbase = ouch-git | ||
2 | pkgdesc = Painless compression and decompression in the terminal (git version) | ||
3 | pkgver = r397.abf1d4e | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/ouch-org/ouch/ | ||
6 | arch = x86_64 | ||
7 | license = MIT | ||
8 | makedepends = git | ||
9 | makedepends = cargo | ||
10 | provides = ouch | ||
11 | conflicts = ouch | ||
12 | conflicts = ouch-bin | ||
13 | source = ouch::git+https://github.com/ouch-org/ouch/ | ||
14 | sha256sums = SKIP | ||
15 | |||
16 | pkgname = ouch-git | ||
diff --git a/ouch-git/PKGBUILD b/ouch-git/PKGBUILD new file mode 100644 index 0000000..8e036ce --- /dev/null +++ b/ouch-git/PKGBUILD | |||
@@ -0,0 +1,51 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | |||
3 | pkgname=ouch-git | ||
4 | _pkgname=${pkgname%-git} | ||
5 | pkgver=r397.abf1d4e | ||
6 | pkgrel=1 | ||
7 | pkgdesc="Painless compression and decompression in the terminal (git version)" | ||
8 | arch=('x86_64') | ||
9 | url="https://github.com/ouch-org/ouch/" | ||
10 | license=('MIT') | ||
11 | makedepends=('git' 'cargo') | ||
12 | provides=(${_pkgname}) | ||
13 | conflicts=(${_pkgname} ${_pkgname}-bin) | ||
14 | source=("${_pkgname}::git+${url}") | ||
15 | sha256sums=('SKIP') | ||
16 | |||
17 | pkgver() { | ||
18 | cd "$srcdir/${_pkgname}" | ||
19 | printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" | ||
20 | } | ||
21 | |||
22 | prepare() { | ||
23 | cd "$srcdir/${_pkgname}" | ||
24 | cargo fetch --locked --target "$CARCH-unknown-linux-gnu" | ||
25 | } | ||
26 | |||
27 | build() { | ||
28 | cd "$srcdir/${_pkgname}" | ||
29 | export RUSTUP_TOOLCHAIN=stable | ||
30 | export CARGO_TARGET_DIR=target | ||
31 | GEN_COMPLETIONS=1 cargo build --frozen --release --all-features | ||
32 | } | ||
33 | |||
34 | check() { | ||
35 | cd "$srcdir/${_pkgname}" | ||
36 | export RUSTUP_TOOLCHAIN=stable | ||
37 | cargo test --frozen --all-features | ||
38 | } | ||
39 | |||
40 | package() { | ||
41 | cd "$srcdir/${_pkgname}" | ||
42 | install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/${_pkgname}" | ||
43 | install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE" | ||
44 | |||
45 | cd target/release/build/ouch-*/out/completions | ||
46 | sed -i "s/':output -- The resulting file. It's extensions can be used to specify the compression formats:_files'/\":output -- The resulting file. It's extensions can be used to specify the compression formats:_files\"/" _ouch | ||
47 | |||
48 | install -Dm0644 ${_pkgname}.bash "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}" | ||
49 | install -Dm0644 ${_pkgname}.fish "${pkgdir}/usr/share/fish/vendor_completions.d/${_pkgname}.fish" | ||
50 | install -Dm0644 _${_pkgname} "${pkgdir}/usr/share/zsh/site-functions/_${_pkgname}" | ||
51 | } | ||