diff options
author | Yigit Sever | 2022-11-27 13:01:26 +0300 |
---|---|---|
committer | Yigit Sever | 2022-11-27 13:01:26 +0300 |
commit | 5bacfc213cecad86e96d2988877b3a10e212f0c7 (patch) | |
tree | 78b39e3703b6c6c941f474fbf55d9d92bb949fb6 /ouch-git | |
parent | b65686d4e4256f45fad660c4739cf3e690d41c05 (diff) | |
download | packages-5bacfc213cecad86e96d2988877b3a10e212f0c7.tar.gz packages-5bacfc213cecad86e96d2988877b3a10e212f0c7.tar.bz2 packages-5bacfc213cecad86e96d2988877b3a10e212f0c7.zip |
ouch-git: Install completions and manpages
Diffstat (limited to 'ouch-git')
-rw-r--r-- | ouch-git/.SRCINFO | 2 | ||||
-rw-r--r-- | ouch-git/PKGBUILD | 21 |
2 files changed, 15 insertions, 8 deletions
diff --git a/ouch-git/.SRCINFO b/ouch-git/.SRCINFO index 8f5b5e1..21b6928 100644 --- a/ouch-git/.SRCINFO +++ b/ouch-git/.SRCINFO | |||
@@ -1,6 +1,6 @@ | |||
1 | pkgbase = ouch-git | 1 | pkgbase = ouch-git |
2 | pkgdesc = Painless compression and decompression in the terminal (git version) | 2 | pkgdesc = Painless compression and decompression in the terminal (git version) |
3 | pkgver = r397.abf1d4e | 3 | pkgver = r693.d4f181b |
4 | pkgrel = 1 | 4 | pkgrel = 1 |
5 | url = https://github.com/ouch-org/ouch/ | 5 | url = https://github.com/ouch-org/ouch/ |
6 | arch = x86_64 | 6 | arch = x86_64 |
diff --git a/ouch-git/PKGBUILD b/ouch-git/PKGBUILD index 8e036ce..7a33f12 100644 --- a/ouch-git/PKGBUILD +++ b/ouch-git/PKGBUILD | |||
@@ -2,7 +2,7 @@ | |||
2 | 2 | ||
3 | pkgname=ouch-git | 3 | pkgname=ouch-git |
4 | _pkgname=${pkgname%-git} | 4 | _pkgname=${pkgname%-git} |
5 | pkgver=r397.abf1d4e | 5 | pkgver=r693.d4f181b |
6 | pkgrel=1 | 6 | pkgrel=1 |
7 | pkgdesc="Painless compression and decompression in the terminal (git version)" | 7 | pkgdesc="Painless compression and decompression in the terminal (git version)" |
8 | arch=('x86_64') | 8 | arch=('x86_64') |
@@ -28,7 +28,7 @@ build() { | |||
28 | cd "$srcdir/${_pkgname}" | 28 | cd "$srcdir/${_pkgname}" |
29 | export RUSTUP_TOOLCHAIN=stable | 29 | export RUSTUP_TOOLCHAIN=stable |
30 | export CARGO_TARGET_DIR=target | 30 | export CARGO_TARGET_DIR=target |
31 | GEN_COMPLETIONS=1 cargo build --frozen --release --all-features | 31 | OUCH_ARTIFACTS_FOLDER=artifacts cargo build --frozen --release --all-features |
32 | } | 32 | } |
33 | 33 | ||
34 | check() { | 34 | check() { |
@@ -39,13 +39,20 @@ check() { | |||
39 | 39 | ||
40 | package() { | 40 | package() { |
41 | cd "$srcdir/${_pkgname}" | 41 | cd "$srcdir/${_pkgname}" |
42 | |||
42 | install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/${_pkgname}" | 43 | install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/${_pkgname}" |
43 | install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE" | 44 | install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE" |
44 | 45 | ||
45 | cd target/release/build/ouch-*/out/completions | 46 | cd artifacts |
46 | sed -i "s/':output -- The resulting file. It's extensions can be used to specify the compression formats:_files'/\":output -- The resulting file. It's extensions can be used to specify the compression formats:_files\"/" _ouch | 47 | |
48 | # install manpages | ||
49 | install -Dm0644 "${_pkgname}.1" -t "${pkgdir}/usr/share/man/man1" | ||
50 | install -Dm0644 "${_pkgname}-compress.1" -t "${pkgdir}/usr/share/man/man1" | ||
51 | install -Dm0644 "${_pkgname}-decompress.1" -t "${pkgdir}/usr/share/man/man1" | ||
52 | install -Dm0644 "${_pkgname}-list.1" -t "${pkgdir}/usr/share/man/man1" | ||
47 | 53 | ||
48 | install -Dm0644 ${_pkgname}.bash "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}" | 54 | # install shell completions |
49 | install -Dm0644 ${_pkgname}.fish "${pkgdir}/usr/share/fish/vendor_completions.d/${_pkgname}.fish" | 55 | install -Dm0644 "${_pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}" |
50 | install -Dm0644 _${_pkgname} "${pkgdir}/usr/share/zsh/site-functions/_${_pkgname}" | 56 | install -Dm0644 "${_pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${_pkgname}.fish" |
57 | install -Dm0644 "_${_pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${_pkgname}" | ||
51 | } | 58 | } |