summaryrefslogtreecommitdiffstats
path: root/ouch-bin
diff options
context:
space:
mode:
authorYigit Sever2023-01-06 15:56:54 +0300
committerYigit Sever2023-01-06 15:56:54 +0300
commit1d3ca9063d376c0555df59c92b05bbafe3319339 (patch)
tree36cf7997bf856e458dca427ba73e08a5e834c7b0 /ouch-bin
parent82954e8ae3ad130fba7a020c99620c25f59c842b (diff)
downloadpackages-1d3ca9063d376c0555df59c92b05bbafe3319339.tar.gz
packages-1d3ca9063d376c0555df59c92b05bbafe3319339.tar.bz2
packages-1d3ca9063d376c0555df59c92b05bbafe3319339.zip
Deleted package: ouch-bin
Deleted package: ouch
Diffstat (limited to 'ouch-bin')
-rw-r--r--ouch-bin/.SRCINFO14
-rw-r--r--ouch-bin/PKGBUILD40
2 files changed, 0 insertions, 54 deletions
diff --git a/ouch-bin/.SRCINFO b/ouch-bin/.SRCINFO
deleted file mode 100644
index 395e550..0000000
--- a/ouch-bin/.SRCINFO
+++ /dev/null
@@ -1,14 +0,0 @@
1pkgbase = ouch-bin
2 pkgdesc = Painless compression and decompression in the terminal (binary release)
3 pkgver = 0.4.0
4 pkgrel = 1
5 url = https://github.com/ouch-org/ouch
6 arch = x86_64
7 license = MIT
8 provides = ouch
9 conflicts = ouch
10 conflicts = ouch-git
11 source = ouch-0.4.0.tar.gz::https://github.com/ouch-org/ouch/releases/download/0.4.0/ouch-x86_64-unknown-linux-gnu.tar.gz
12 sha256sums = 4b03c6a54b12e2038600cfb450aebac70bd9516fc9bf50a78c93f93fef75e60b
13
14pkgname = ouch-bin
diff --git a/ouch-bin/PKGBUILD b/ouch-bin/PKGBUILD
deleted file mode 100644
index 0641836..0000000
--- a/ouch-bin/PKGBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=ouch-bin
4_pkgname=${pkgname%-bin}
5pkgver=0.4.0
6pkgrel=1
7pkgdesc="Painless compression and decompression in the terminal (binary release)"
8arch=('x86_64')
9url="https://github.com/ouch-org/ouch"
10license=('MIT')
11provides=(${_pkgname})
12conflicts=(${_pkgname} ${_pkgname}-git)
13source=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/${pkgver}/ouch-x86_64-unknown-linux-gnu.tar.gz")
14sha256sums=('4b03c6a54b12e2038600cfb450aebac70bd9516fc9bf50a78c93f93fef75e60b')
15
16package() {
17 # Binary releaes is archived in a folder with a generic name, it is not ideal
18 # (e.g. aur helpers will complain about name clashes)
19 # So we fix it
20 cd "${srcdir}"
21 mkdir "${_pkgname}-${pkgver}"
22 mv "${srcdir}/ouch-x86_64-unknown-linux-gnu/"* "${_pkgname}-${pkgver}"
23 rmdir ouch-x86_64-unknown-linux-gnu
24
25 cd "${srcdir}/${_pkgname}-${pkgver}"
26
27 install -Dm0755 -t "${pkgdir}/usr/bin" "${_pkgname}"
28 install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
29
30 # install manpages
31 install -Dm0644 "man/${_pkgname}.1" -t "${pkgdir}/usr/share/man/man1"
32 install -Dm0644 "man/${_pkgname}-compress.1" -t "${pkgdir}/usr/share/man/man1"
33 install -Dm0644 "man/${_pkgname}-decompress.1" -t "${pkgdir}/usr/share/man/man1"
34 install -Dm0644 "man/${_pkgname}-list.1" -t "${pkgdir}/usr/share/man/man1"
35
36 # install shell completions
37 install -Dm0644 "completions/${_pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
38 install -Dm0644 "completions/${_pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${_pkgname}.fish"
39 install -Dm0644 "completions/_${_pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${_pkgname}"
40}