summaryrefslogtreecommitdiffstats
path: root/osh/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2022-01-03 11:28:03 +0300
committerYigit Sever2022-01-03 11:29:02 +0300
commit66ce802c1a19891803fcaccbcdb8cdee70b65ea1 (patch)
treea85ad3ed9c5e6bd2f01e4f54b93dde315248aaf1 /osh/PKGBUILD
parenta8acc8a4603b6617764fcc5d3fac5f53d38dd8a5 (diff)
downloadpackages-66ce802c1a19891803fcaccbcdb8cdee70b65ea1.tar.gz
packages-66ce802c1a19891803fcaccbcdb8cdee70b65ea1.tar.bz2
packages-66ce802c1a19891803fcaccbcdb8cdee70b65ea1.zip
osh: moved to community
Diffstat (limited to 'osh/PKGBUILD')
-rw-r--r--osh/PKGBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/osh/PKGBUILD b/osh/PKGBUILD
deleted file mode 100644
index 83b3c8a..0000000
--- a/osh/PKGBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Qontinuum <[email protected]>
3# Contributor: timetoplatypus <[email protected]>
4# Contributor: andychu <[email protected]>
5
6pkgname=osh
7pkgver=0.9.6
8pkgrel=1
9pkgdesc="Oil Shell - A bash-compatible UNIX shell written in Python"
10arch=('any')
11url="https://www.oilshell.org/"
12license=("Apache")
13options=(!strip)
14optdepends=("readline: interactive features")
15source=("https://www.oilshell.org/download/oil-$pkgver.tar.xz")
16sha256sums=('e1c7d1cac276d36cb5f7de9307fee3be558ee4adaf349ef422322400d5c8a5c4')
17
18prepare() {
19 mkdir -p tmp
20 sed 's/TMP=${TMPDIR:-\/tmp}/TMP=..\/tmp/' -i "oil-$pkgver/configure"
21}
22
23build() {
24 cd "oil-$pkgver"
25 ./configure --prefix="/usr"
26 make $MAKEFLAGS
27}
28
29package() {
30 cd "oil-$pkgver"
31 DESTDIR="$pkgdir/" ./install
32}