diff options
author | Yigit Sever | 2023-06-21 04:11:03 +0300 |
---|---|---|
committer | Yigit Sever | 2023-06-21 04:11:03 +0300 |
commit | 61d8cb01f3d5d285c6eb9331053e287e4c220de5 (patch) | |
tree | 06f583f66b46592220909be7abd52857110f9571 /httpx-bin | |
parent | 537d71f1f1f923c9fbdf95807877c5c173ecc442 (diff) | |
download | packages-61d8cb01f3d5d285c6eb9331053e287e4c220de5.tar.gz packages-61d8cb01f3d5d285c6eb9331053e287e4c220de5.tar.bz2 packages-61d8cb01f3d5d285c6eb9331053e287e4c220de5.zip |
Deleted package: httpx-bin
Diffstat (limited to 'httpx-bin')
-rw-r--r-- | httpx-bin/.SRCINFO | 20 | ||||
-rw-r--r-- | httpx-bin/.gitignore | 5 | ||||
-rw-r--r-- | httpx-bin/PKGBUILD | 28 |
3 files changed, 0 insertions, 53 deletions
diff --git a/httpx-bin/.SRCINFO b/httpx-bin/.SRCINFO deleted file mode 100644 index 4cabdeb..0000000 --- a/httpx-bin/.SRCINFO +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | pkgbase = httpx-bin | ||
2 | pkgdesc = Fast and multi-purpose HTTP toolkit | ||
3 | pkgver = 1.3.2 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/projectdiscovery/httpx | ||
6 | arch = x86_64 | ||
7 | arch = armv6h | ||
8 | arch = aarch64 | ||
9 | license = MIT | ||
10 | provides = httpx | ||
11 | conflicts = httpx | ||
12 | options = !strip | ||
13 | source_x86_64 = httpx-1.3.2-x86_64.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.3.2/httpx_1.3.2_linux_amd64.zip | ||
14 | sha256sums_x86_64 = 9d26576bb4b636cba10de0031fd91da0c35219a771ed0339cccdb57ed434d5be | ||
15 | source_armv6h = httpx-1.3.2-armv6.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.3.2/httpx_1.3.2_linux_armv6.zip | ||
16 | sha256sums_armv6h = 572e2ed32ea19f5a1dbde4b1110db46a9f542545d01919681144227eff4e4f9f | ||
17 | source_aarch64 = httpx-1.3.2-aarch64.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.3.2/httpx_1.3.2_linux_arm64.zip | ||
18 | sha256sums_aarch64 = 73c1f21709abd6678751d25af132e81030714c75faba9568107902e69259f993 | ||
19 | |||
20 | pkgname = httpx-bin | ||
diff --git a/httpx-bin/.gitignore b/httpx-bin/.gitignore deleted file mode 100644 index 623d0e7..0000000 --- a/httpx-bin/.gitignore +++ /dev/null | |||
@@ -1,5 +0,0 @@ | |||
1 | * | ||
2 | !.gitignore | ||
3 | !.SRCINFO | ||
4 | !PKGBUILD | ||
5 | |||
diff --git a/httpx-bin/PKGBUILD b/httpx-bin/PKGBUILD deleted file mode 100644 index bfca97a..0000000 --- a/httpx-bin/PKGBUILD +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz> | ||
3 | |||
4 | _pkgname='httpx' | ||
5 | pkgname="${_pkgname}-bin" | ||
6 | pkgver=1.3.2 | ||
7 | pkgrel=1 | ||
8 | pkgdesc='Fast and multi-purpose HTTP toolkit' | ||
9 | arch=('x86_64' 'armv6h' 'aarch64') | ||
10 | url='https://github.com/projectdiscovery/httpx' | ||
11 | license=('MIT') | ||
12 | provides=("${_pkgname}") | ||
13 | conflicts=("${_pkgname}") | ||
14 | options=('!strip') | ||
15 | |||
16 | source_x86_64=("${_pkgname}-${pkgver}-x86_64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.zip") | ||
17 | source_armv6h=("${_pkgname}-${pkgver}-armv6.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_armv6.zip") | ||
18 | source_aarch64=("${_pkgname}-${pkgver}-aarch64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.zip") | ||
19 | |||
20 | sha256sums_x86_64=('9d26576bb4b636cba10de0031fd91da0c35219a771ed0339cccdb57ed434d5be') | ||
21 | sha256sums_armv6h=('572e2ed32ea19f5a1dbde4b1110db46a9f542545d01919681144227eff4e4f9f') | ||
22 | sha256sums_aarch64=('73c1f21709abd6678751d25af132e81030714c75faba9568107902e69259f993') | ||
23 | |||
24 | package() { | ||
25 | install -Dvm755 "${_pkgname}" -t "${pkgdir}/usr/bin" | ||
26 | install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}" | ||
27 | install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE" | ||
28 | } | ||