summaryrefslogtreecommitdiffstats
path: root/httpx-bin/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2023-01-06 17:05:23 +0300
committerYigit Sever2023-01-06 17:05:23 +0300
commitadd41db5917399d90bfd9bfbee07386dd935444f (patch)
tree6777384bcb1be67b982bfe5ac75558253426a949 /httpx-bin/PKGBUILD
parentcaf19250b8e3ce04849717d77a28d1ffd49dcfe8 (diff)
downloadpackages-add41db5917399d90bfd9bfbee07386dd935444f.tar.gz
packages-add41db5917399d90bfd9bfbee07386dd935444f.tar.bz2
packages-add41db5917399d90bfd9bfbee07386dd935444f.zip
Deleted package: httpx-bin
Diffstat (limited to 'httpx-bin/PKGBUILD')
-rw-r--r--httpx-bin/PKGBUILD28
1 files changed, 0 insertions, 28 deletions
diff --git a/httpx-bin/PKGBUILD b/httpx-bin/PKGBUILD
deleted file mode 100644
index 28a190c..0000000
--- a/httpx-bin/PKGBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3
4_pkgname='httpx'
5pkgname="${_pkgname}-bin"
6pkgver=1.2.5
7pkgrel=1
8pkgdesc='Fast and multi-purpose HTTP toolkit'
9arch=('x86_64' 'armv6h' 'aarch64')
10url='https://github.com/projectdiscovery/httpx'
11license=('MIT')
12provides=("${_pkgname}")
13conflicts=("${_pkgname}")
14options=('!strip')
15
16source_x86_64=("${_pkgname}-${pkgver}-x86_64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.zip")
17source_armv6h=("${_pkgname}-${pkgver}-armv6.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_armv6.zip")
18source_aarch64=("${_pkgname}-${pkgver}-aarch64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.zip")
19
20sha256sums_x86_64=('4dc46e5246b48fbfe1ba34dc574c55b77b6ee3e02e3a62e8bca1f2f4434a42b0')
21sha256sums_armv6h=('21b170e20df58f6fcd38af81328588c8d381e3b8972dbff2b90d6fec3678ec2a')
22sha256sums_aarch64=('4dd120cdb8b034cb56c49c261e018f4f344c7864eca9321d3316042130cc736f')
23
24package() {
25 install -Dvm755 "${_pkgname}" -t "${pkgdir}/usr/bin"
26 install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}"
27 install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
28}