diff options
author | Yigit Sever | 2021-10-29 01:30:24 +0300 |
---|---|---|
committer | Yigit Sever | 2021-10-29 01:30:24 +0300 |
commit | 31d147b20c67d95a9e306d0749200bf964ac42af (patch) | |
tree | b0fbe2bb5aa0fec9983746a91d188643ca93466d /httpx-bin/PKGBUILD | |
parent | 4a31e5e0f3442a4a5ec9fba94f7bbc2c88312c69 (diff) | |
download | packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.gz packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.bz2 packages-31d147b20c67d95a9e306d0749200bf964ac42af.zip |
Use actual files instead of submodules
Diffstat (limited to 'httpx-bin/PKGBUILD')
-rw-r--r-- | httpx-bin/PKGBUILD | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/httpx-bin/PKGBUILD b/httpx-bin/PKGBUILD new file mode 100644 index 0000000..9f7eefb --- /dev/null +++ b/httpx-bin/PKGBUILD | |||
@@ -0,0 +1,28 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz> | ||
3 | |||
4 | _pkgname='httpx' | ||
5 | pkgname="${_pkgname}-bin" | ||
6 | pkgver=1.1.3 | ||
7 | pkgrel=1 | ||
8 | pkgdesc='Fast and multi-purpose HTTP toolkit' | ||
9 | arch=('x86_64' 'armv6h' 'aarch64') | ||
10 | url='https://github.com/projectdiscovery/httpx' | ||
11 | license=('MIT') | ||
12 | provides=("${_pkgname}") | ||
13 | conflicts=("${_pkgname}") | ||
14 | options=('!strip') | ||
15 | |||
16 | source_x86_64=("${_pkgname}-${pkgver}-x86_64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.zip") | ||
17 | source_armv6h=("${_pkgname}-${pkgver}-armv6.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_armv6.zip") | ||
18 | source_aarch64=("${_pkgname}-${pkgver}-aarch64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.zip") | ||
19 | |||
20 | sha256sums_x86_64=('eadd0031b57b4caf29d59740a6d4a25dc86140e8303566849371e749345a9e82') | ||
21 | sha256sums_armv6h=('7d693eb41669be2723ef35442c67133ebdb108e319f0cf4c0f7bf659cdad9b70') | ||
22 | sha256sums_aarch64=('f0e80a29799b6d28f1f28878976825bd079376aea141b41bb8af8e6f3ac18da6') | ||
23 | |||
24 | package() { | ||
25 | install -Dvm755 "${_pkgname}" -t "${pkgdir}/usr/bin" | ||
26 | install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}" | ||
27 | install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE" | ||
28 | } | ||