summaryrefslogtreecommitdiffstats
path: root/gourmand/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2021-10-29 01:30:24 +0300
committerYigit Sever2021-10-29 01:30:24 +0300
commit31d147b20c67d95a9e306d0749200bf964ac42af (patch)
treeb0fbe2bb5aa0fec9983746a91d188643ca93466d /gourmand/PKGBUILD
parent4a31e5e0f3442a4a5ec9fba94f7bbc2c88312c69 (diff)
downloadpackages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.gz
packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.bz2
packages-31d147b20c67d95a9e306d0749200bf964ac42af.zip
Use actual files instead of submodules
Diffstat (limited to 'gourmand/PKGBUILD')
-rw-r--r--gourmand/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/gourmand/PKGBUILD b/gourmand/PKGBUILD
new file mode 100644
index 0000000..92e52c9
--- /dev/null
+++ b/gourmand/PKGBUILD
@@ -0,0 +1,37 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname='gourmand'
4pkgver=1.0.0
5pkgrel=3
6pkgdesc="A recipe manager for desktop that can import recipes"
7arch=('any')
8url="https://github.com/GourmandRecipeManager/gourmand"
9license=('GPL')
10depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy' 'python-lxml' 'python-cairo' 'python-requests')
11makedepends=('python-pip' 'gendesk')
12checkdepends=()
13optdepends=(
14 'python-beautifulsoup4: Webpage import plugin'
15 'python-scrape-schema-recipe: Webpage import plugin'
16 'python-selenium'
17 'python-keyring'
18 'python-ebooklib: EPub export plugin'
19 'python-reportlab: Printing & PDF export plugin'
20 'python-gtkspellcheck: Spell checking plugin'
21 'nuspell: Spell checking'
22 'hspell: Spell checking for Hebrew'
23 'libvoikko: Spell checking for Finnish language'
24 )
25conflicts=('gourmet')
26source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl")
27sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4')
28
29prepare() {
30 gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc"
31}
32
33package() {
34 # https://wiki.archlinux.org/title/Python_package_guidelines#pip
35 PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
36 install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
37}