summaryrefslogtreecommitdiffstats
path: root/euterpe/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2021-10-29 01:30:24 +0300
committerYigit Sever2021-10-29 01:30:24 +0300
commit31d147b20c67d95a9e306d0749200bf964ac42af (patch)
treeb0fbe2bb5aa0fec9983746a91d188643ca93466d /euterpe/PKGBUILD
parent4a31e5e0f3442a4a5ec9fba94f7bbc2c88312c69 (diff)
downloadpackages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.gz
packages-31d147b20c67d95a9e306d0749200bf964ac42af.tar.bz2
packages-31d147b20c67d95a9e306d0749200bf964ac42af.zip
Use actual files instead of submodules
Diffstat (limited to 'euterpe/PKGBUILD')
-rw-r--r--euterpe/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/euterpe/PKGBUILD b/euterpe/PKGBUILD
new file mode 100644
index 0000000..024a7a2
--- /dev/null
+++ b/euterpe/PKGBUILD
@@ -0,0 +1,34 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=euterpe
4pkgver=1.5.1
5pkgrel=1
6pkgdesc='Self-hosted music streaming server with RESTful API and Web interface'
7arch=('x86_64')
8url="https://github.com/ironsmile/$pkgname"
9license=('GPL')
10depends=('taglib' 'icu')
11makedepends=('go')
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
13sha256sums=('f3b1ef13b2b64d40255a01ff954c409a1b8c22df7f75a1634185ac79219edb04')
14
15prepare(){
16 cd "$pkgname-$pkgver"
17 mkdir -p build/
18}
19
20build() {
21 cd "$pkgname-$pkgver"
22 export CGO_CPPFLAGS="${CPPFLAGS}"
23 export CGO_CFLAGS="${CFLAGS}"
24 export CGO_CXXFLAGS="${CXXFLAGS}"
25 export CGO_LDFLAGS="${LDFLAGS}"
26 export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
27
28 go build -o build
29}
30
31package() {
32 cd "$pkgname-$pkgver"
33 install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
34}