summaryrefslogtreecommitdiffstats
path: root/dnsx
diff options
context:
space:
mode:
authorYigit Sever2023-02-16 16:52:01 +0300
committerYigit Sever2023-02-16 16:52:01 +0300
commit7e8b0f54a876dae77f0bf252da798c3b6fa32507 (patch)
tree3a2693a580f191fae55c68d6b0f7830461fa6b3c /dnsx
parentfe7453f2b167500aff44f3281514836362531b3d (diff)
downloadpackages-7e8b0f54a876dae77f0bf252da798c3b6fa32507.tar.gz
packages-7e8b0f54a876dae77f0bf252da798c3b6fa32507.tar.bz2
packages-7e8b0f54a876dae77f0bf252da798c3b6fa32507.zip
Deleted package: dnsx
Diffstat (limited to 'dnsx')
-rw-r--r--dnsx/.SRCINFO13
-rw-r--r--dnsx/.gitignore4
-rw-r--r--dnsx/PKGBUILD37
3 files changed, 0 insertions, 54 deletions
diff --git a/dnsx/.SRCINFO b/dnsx/.SRCINFO
deleted file mode 100644
index 52b09eb..0000000
--- a/dnsx/.SRCINFO
+++ /dev/null
@@ -1,13 +0,0 @@
1pkgbase = dnsx
2 pkgdesc = Fast and multi-purpose DNS toolkit
3 pkgver = 1.1.2
4 pkgrel = 1
5 url = https://github.com/projectdiscovery/dnsx
6 arch = x86_64
7 license = MIT
8 makedepends = go
9 provides = dnsx
10 source = dnsx-1.1.2.tar.gz::https://github.com/projectdiscovery/dnsx/archive/v1.1.2.tar.gz
11 sha256sums = fd2375639c00021c99e69071011df64aa233f07aa6935968880ec134412dd993
12
13pkgname = dnsx
diff --git a/dnsx/.gitignore b/dnsx/.gitignore
deleted file mode 100644
index 05c6d4d..0000000
--- a/dnsx/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
1*
2!.gitignore
3!.SRCINFO
4!PKGBUILD
diff --git a/dnsx/PKGBUILD b/dnsx/PKGBUILD
deleted file mode 100644
index d37017d..0000000
--- a/dnsx/PKGBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3
4pkgname='dnsx'
5pkgver=1.1.2
6pkgrel=1
7pkgdesc='Fast and multi-purpose DNS toolkit'
8arch=('x86_64')
9url='https://github.com/projectdiscovery/dnsx'
10license=('MIT')
11makedepends=('go')
12provides=("${pkgname}")
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
14sha256sums=('fd2375639c00021c99e69071011df64aa233f07aa6935968880ec134412dd993')
15
16prepare() {
17 export GOPATH="${srcdir}/gopath"
18 go clean -modcache
19}
20
21build() {
22 export CGO_CPPFLAGS="${CPPFLAGS}"
23 export CGO_CFLAGS="${CFLAGS}"
24 export CGO_CXXFLAGS="${CXXFLAGS}"
25 export CGO_LDFLAGS="${LDFLAGS}"
26 export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
27
28 cd "${pkgname}-${pkgver}/cmd/${pkgname}"
29 go build -v -o "${pkgname}" .
30}
31
32package() {
33 cd "${pkgname}-${pkgver}"
34 install -Dvm755 "cmd/${pkgname}/${pkgname}" -t "${pkgdir}/usr/bin"
35 install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
36 install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
37}